Результаты поиска по запросу "setuptools"

1 ответ

Setuptools не может использовать ссылку из зависимых_линков

Я пытался установить пакет со следующей настройкой: setup( packages=find_packages(), include_package_data=True, install_requires=[ 'Django==1.5.1', 'xhtml2pdf', ], ...

1 ответ

Изменить папку dist по умолчанию с помощью setuptools

2 ответа

Это не относится к пакетам, которые содержат скомпилированный двоичный код. Я не думаю, что это действительно полностью решает проблему здесь.

не остановитьсяsetup.py от установки пакета как яйцо? Или даже лучше, как мнеeasy_install от установки пакета в качествеegg? sudo python setup.py установить Причина в том, чтоPyDev довольно требователен к пакетам вegg формат ... интересующий ...

ТОП публикаций

7 ответов

«Setup.py upload» завершается с ошибкой «Ошибка загрузки (401): вы должны быть идентифицированы для редактирования информации о пакете»

1 ответ

Используйте setuptools для установки с места

2 ответа

Установка SetupTools в 64-битной Windows

2 ответа

Какая альтернатива использованию --process-dependency-links с pip

Я использую Python 2.7. я пытаюсь

0 ответов

Какой стандартный способ упаковки проекта Python с зависимостями?

У меня есть проект Python, который имеет несколько зависимостей (определяется в

1 ответ

Лучший способ поделиться кодом между несколькими скриптами setup.py?

У меня есть несколько пакетов, над которыми я работаю, и я хотел бы поделиться кодом между их сценариями setup.py. Есть ли хороший способ сделать это, или ду...

1 ответ

Манифест определяет, что входит в исходный дистрибутив, но package_data - это то, что используется для определения любых файлов данных, которые вы хотите установить вместе с исходными файлами Python в расположении пакета (site-packages). Эти файлы в MANIFEST.in могут не быть документами или другими файлами, которые вы не хотите устанавливать там, но хотите в исходном дистрибутиве.

я естьsetup.py файл, который выглядит так: #!/usr/bin/env python from setuptools import setup, find_packages setup( name="foo", version="1.0", packages=find_packages(), include_package_data=True, package_data={ "": ["*"], }, )И пакетfoo который ...