ADT 22.3 (android 4.4) - получение ошибки «После создания сцены должен быть вызван #init ()»

После установки нового ADT (22.3.0.v201310242005-887826), который поддерживает Android 4.4 (KitKat), я продолжаю получать сообщение об ошибке, как показано здесь:

Произошла внутренняя ошибка

В списке ошибок я вижу несколько пунктов "RenderPreview»и когда я нажимаю на любой из них, я вижу:

Произошла внутренняя ошибка. После создания сцены необходимо вызвать #init ()

При тестировании нового ADT на другом компьютере я могуэта ошибка не появляется Это очень странно.

Почему я получаю эти ошибки, и что я могу сделать, чтобы исправить это?

 Zafer Celaloglu20 нояб. 2014 г., 11:48
да, я знаю это, но функция не работает под 19 API.
 android developer20 нояб. 2014 г., 08:54
@ZaferCelaloglu Я нене знаю о классе Scene, но чтобы поддерживать более низкие API, вам нужно установить "minSdkVersion» в манифесте. "targetSdkVersion» должен быть установлен максимально доступный (который в настоящее время 21). Я предлагаю прочитать документацию:developer.android.com/guide/topics/manifest/...
 android developer03 нояб. 2013 г., 13:44
@DixieFlatline это 'хорошо. это значит, что я нене делай ничего плохого (на этот раз :))
 Zafer Celaloglu20 нояб. 2014 г., 07:57
Я также использую класс Scene в своем проекте (для запуска перехода), но минимальная версия API 19, но я хочу поддерживать до 19 лет, как я могу это изменить?
 DixieFlatline03 нояб. 2013 г., 12:46
У меня такие же проблемы.
 android developer20 нояб. 2014 г., 16:31
@ZaferCelaloglu Какую функцию вы пытаетесь использовать? Есть много классов / функций, которые могут преодолеть это внутри библиотеки поддержки и сторонних библиотек. Если нетт, вы всегда можете выполнить проверку:если (VERSION.SDK_INT>= VERSION_CODES.KITKAT) ... ".I '
 Guy03 нояб. 2013 г., 21:53
Точно такая же проблема, я просто тоже открылвопрос себя. Didn»не вижу вашего вопроса раньше.

Ответы на вопрос(6)

Решение Вопроса

мы создалисообщение об ошибке, Пока это не будет исправлено, установите версию API в предварительном просмотре пользовательского интерфейса на значение ниже 19. Ошибка появляется только для версии 19.

 andikurnia15 дек. 2013 г., 12:58
ах, спасибо за ваш ответ Сегодня получил эту ошибку после обновления в kitkat ... странно
 SimonSays30 дек. 2013 г., 20:19
Да, подтверждено Последнее обновление SDK устраняет проблему.
 SimonSays25 нояб. 2013 г., 19:05
К вашему сведению: статус ошибки установлен на "фиксированный"Я думаю, это будет частью следующего обновления ADT.
 android developer05 нояб. 2013 г., 22:56
какие'странно, что на некоторых компьютерахт происходит.
 android developer22 дек. 2013 г., 14:30
Кажется, что эта ошибка была исправлена. я'обновил SDK (до 22,3?м не уверен) и теперь работает нормально.

Просто прокрутите вниз от API 19 до API 18, Изображение Android в графическом макете.

После установки нового ADT (22.3.0.v201310242005-887826), который поддерживает Android 4.4 (kitkat), я получил такую же ошибку.

Затем установите версию API в предварительном просмотре пользовательского интерфейса на значение ниже 19. Ошибка отображается только для версии 19.

У меня такой же опыт, но одно понижение до Android4.3 (Jelly Bean) для меня сейчас только удачное временное решение.

 android developer04 нояб. 2013 г., 07:28
К сожалению, тот же компьютер также имеет другую проблему (с пользовательскими представлениями) в конструкторе пользовательского интерфейса, независимо от того, какой ADT он имеет. Я'мы сообщили об этом здесь:stackoverflow.com/questions/18119907/...
 bruno.braga05 нояб. 2013 г., 02:47
то же самое здесь со мной.

На мой взгляд, это новый баг. Может быть, нам нужно подождать, пока Google обновит его.

Временное решение, пока Google не исправит его:

Обходной путь: Переключитесь на Android-18 в графическом макете (зеленый Android вверху справа).

Ссылка: вопрос переполнения стекаКак исправить Eclipse ADT Plugin 22.3 / SDK Tools 22.3 с неработающим окном свойств?

Ваш ответ на вопрос