Resultados de la búsqueda a petición "cabal-install"

2 la respuesta

Instalar paquetes Haskell usando cabal sin conexión a internet

Tengo una máquina que no tiene acceso a Internet en absoluto. Instalé la plataforma Haskell usando el instalador que obtuve de otra máquina a través de un pendrive. Ahora quiero instalar el paqueterepa en la máquina de mi casa que no ...

1 la respuesta

Haskell - Paquete de cabal de embalaje con preprocesadores personalizados

He implementado un preprocesador personalizado que crea archivos * .hs desde archivos * .tpl. Se especifica en

2 la respuesta

documentation para el archivo de configuración cabal-install

Los~/.cabal/config almacena la configuración que utiliza cabal-install. Quería hacer algo de piratería al respecto. (Específicamente, teniendo varias versiones de GHC instaladas, deseo tener índices de documentación separados). in embargo, no ...

2 la respuesta

Cabal falla con proxy con autenticación

Este es un error bien conocido quecabal no puede manejar proxies en formatohttp://user:[email protected]:port formato. En la lista de correo de Haskell, alguien sugirió un parche para superar esto, pero ese parche ahora es bastante antiguo. Falla ...

1 la respuesta

cabal install cabal-install errores en linux

Estoy usando Linux (Centos 6.6). Cuando intento ejecutar el comando cabal install cabal-install obtengo los siguientes errores cabal: cannot configure unix-2.7.0.1. It requires base >=4.5 && <4.8 For the dependency on base >=4.5 && <4.8 there ...

1 la respuesta

Actualiza Cabal en Ubuntu 14.04

Cuando instalo Haskell / GHC + cabal a través desudo apt-get Instalé cabal versión 1.16. Obviamente, esta no es la versión más actualizada. ¿Cómo haría para actualizar al menos a la versión 1.18? Intenté hacersudo apt-get update ysudo apt-get ...

1 la respuesta

Instalar Cabal-dev en windows 7

1 la respuesta

Paquete Haskell instalado pero no encontrado

Instalé diagramas, y parece estar allí, pero GHCi no lo encuentra. Intenté agregar el sandbox local a la línea de comando (-package-db), pero aún así no tuve suerte. ¿Alguna sugerencia? C:\Users\guthrie> C:\Users\guthrie>cabal install diagrams ...

1 la respuesta

No se puede instalar sdl2 a través de cabal

Estoy tratando de instalarhelm. Cuando trato de instalarlo, sin embargo, aparece este error: $ cabal install helm Resolving dependencies... Configuring sdl2-1.1.0... cabal: The pkg-config package 'sdl2' version >=2.0.3 is required but it could ...

4 la respuesta

Cuando intento instalar hlint obtengo errores relacionados con old-time-1.1.0.3

Primero intenté instalar Hlint.cabal install hlint pero luego recibí el error: cabal: Error: some packages failed to install: cpphs-1.20.2 depends on old-time-1.1.0.3 which failed to install. haskell-src-exts-1.18.2 depends on old-time-1.1.0.3 ...