Что означает ключ «Приложение требует среды iPhone» в info.plist?

У меня проблемы с пониманием конкретных требований вinfo.plist файл в моем приложении. Должен ли я вообще его изменить, или настройки по умолчанию обычно являются & quot; правильными & quot; опции?

В частности, запись:APPLICATION REQUIRES IPHONE ENVIRONMENT

Если установлено значение «да», означает ли это толькоiPhone способен запускать мое приложение, что означает, что iPod Touch или iPad не смогут запустить приложение?

Ответы на вопрос(1)

Решение Вопроса

Здесь & APOS; sДокументация Apple по «LSRequiresiPhoneOS» биты файла info.plist приложения.

В основном это означает, что приложение предназначено для работы под iOS. Этот флаг должен быть установлен в ДА, независимо от того, является ли целевое устройство iPhone, iPod Touch или iPad.

Кто знает, может быть, в недалеком будущем MacOS сможет запускать приложения для iOS (или наоборот)?

 24 мая 2013 г., 18:53
или (размышляя) Apple TV может попасть туда
 20 янв. 2016 г., 06:24
^ Кажется, более вероятно, учитывая странно вводящее в заблуждение имя. Я предполагаю, что все приземлились здесь, потому что они волновались, это означало, что их приложение не будет работать на iPad
 17 окт. 2014 г., 11:34
Не является ли это артефактом самых ранних дней «iPhoneOS», когда iPod продавался без него, но его можно было обновить до iPhoneOS и позволить им использоватьnew Магазин приложений? Я не думаю, что это оfuture возможности.
 25 сент. 2014 г., 05:58
Сегодня я заархивировал свое приложение, и оно давало мне.pkg файл, поэтому я добавил этот ключ, и теперь я добавил этот ключ, чтобы я мог заархивировать его как.ipa файл (xcode 6.0.1)

Ваш ответ на вопрос