Проблемы запуска Eclipse

Внезапно «Затмение», которое раньше работало, отлично выиграло ».больше не запускать. Вот журнал:

!SESSION 2012-11-13 11:10:21.718 -----------------------------------------------
eclipse.buildId=M20060921-0945
java.version=1.7.0_09
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ko_KR
Framework arguments:  -vm C:\j2sdk1.4.2_19\bin\javaw.exe
Command-line arguments:  -os win32 -ws win32 -arch x86 -vm C:\j2sdk1.4.2_19\bin\javaw.exe

!ENTRY org.eclipse.equinox.common 4 0 2012-11-13 11:10:23.281
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:294)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:329)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1046)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:573)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:495)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:455)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

!ENTRY org.eclipse.update.configurator 4 0 2012-11-13 11:10:23.312
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:294)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:329)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1046)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:573)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:495)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:455)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

!ENTRY org.eclipse.core.runtime 4 0 2012-11-13 11:10:23.328
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:294)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:329)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1046)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:573)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:495)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:275)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:455)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:189)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:291)

!ENTRY org.eclipse.osgi 4 0 2012-11-13 11:10:23.328
!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2012-11-13 11:10:23.328
!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.update.configurator_3.2.2.R32x_v20070111.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2012-11-13 11:10:23.328
!MESSAGE Bundle [email protected]:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2012-11-13 11:10:23.343
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:65)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
    at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
    at org.eclipse.core.launcher.Main.run(Main.java:977)
    at org.eclipse.core.launcher.Main.main(Main.java:952)

!ENTRY org.eclipse.osgi 2 0 2012-11-13 11:10:23.625
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.625
!MESSAGE Bundle [email protected]/com.ibm.etools.emf.event_3.0.0.v20060918_M.jar [4] was not resolved.
!SUBENTRY 2 com.ibm.etools.emf.event 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.eclipse.emf.ecore_[2.2.0,3.0.0).
!SUBENTRY 2 com.ibm.etools.emf.event 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.eclipse.core.runtime.compatibility_[3.1.0,4.0.0).
!SUBENTRY 2 com.ibm.etools.emf.event 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.eclipse.core.runtime_[2.1.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.625
!MESSAGE Bundle [email protected]/com.jcraft.jsch_0.1.28.jar [7] was not resolved.
!SUBENTRY 2 com.jcraft.jsch 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.4
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.625
!MESSAGE Bundle [email protected]/org.apache.ant_1.6.5/ [8] was not resolved.
!SUBENTRY 2 org.apache.ant 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.2
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.625
!MESSAGE Bundle [email protected]/org.apache.axis_1.3.0.v200608161946/ [9] was not resolved.
!SUBENTRY 2 org.apache.axis 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.apache.ant_[1.6.5,1.7.0).
!SUBENTRY 2 org.apache.axis 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing optionally required bundle org.apache.commons.httpclient_[3.0.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.625
!MESSAGE Bundle [email protected]/org.apache.lucene_1.4.103.v20060601/ [13] was not resolved.
!SUBENTRY 2 org.apache.lucene 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.3
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.625
!MESSAGE Bundle [email protected]/org.apache.wsil4j_1.0.0.v200608161946/ [14] was not resolved.
!SUBENTRY 2 org.apache.wsil4j 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.uddi4j_[2.0.4,2.1.0).
!SUBENTRY 2 org.apache.wsil4j 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.apache.axis_[1.3.0,1.4.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.625
!MESSAGE Bundle [email protected]/org.eclipse.ant.core_3.1.100.v20060531.jar [16] was not resolved.
!SUBENTRY 2 org.eclipse.ant.core 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.eclipse.core.variables_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.core 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.625
!MESSAGE Bundle [email protected]/org.eclipse.ant.ui_3.2.1.r321_v20060828.jar [17] was not resolved.
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing optionally required bundle org.eclipse.ui.ide_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing optionally required bundle org.eclipse.ui.views_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing optionally required bundle org.eclipse.jface.text_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing optionally required bundle org.eclipse.ui.workbench.texteditor_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing optionally required bundle org.eclipse.ui.editors_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.apache.ant_1.6.5.
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.eclipse.ant.core_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.eclipse.core.filesystem_[1.0.0,2.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.eclipse.core.resources_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.625
!MESSAGE Missing required bundle org.eclipse.core.filebuffers_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.core.variables_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.ui.externaltools_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.ui_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.ui.console_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.debug.core_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.debug.ui_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.jdt.ui_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.jdt.debug.ui_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.jdt.launching_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.jdt.core_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.team.core_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.ltk.core.refactoring_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.core.expressions_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.ant.ui 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing imported package com.ibm.icu.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.640
!MESSAGE Bundle [email protected]/org.eclipse.compare_3.2.1.M20060711.jar [18] was not resolved.
!SUBENTRY 2 org.eclipse.compare 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.ui_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.core.resources_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.jface.text_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.ui.ide_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.ui.views_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.ui.workbench.texteditor_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.core.runtime_[3.1.0,4.0.0).
!SUBENTRY 2 org.eclipse.compare 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing imported package com.ibm.icu.util_0.0.0.
!SUBENTRY 2 org.eclipse.compare 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing imported package com.ibm.icu.text_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.640
!MESSAGE Bundle [email protected]/org.eclipse.core.boot_3.1.100.v20060603.jar [19] was not resolved.
!SUBENTRY 2 org.eclipse.core.boot 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.640
!MESSAGE Bundle [email protected]/org.eclipse.core.commands_3.2.0.I20060605-1400.jar [20] was not resolved.
!SUBENTRY 2 org.eclipse.core.commands 2 0 2012-11-13 11:10:23.640
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 1 org.eclipse.osgi 2 0 2012-11-13 11:10:23.640
!MESSAGE Bundle [email protected]/org.eclipse.core.contenttype_3.2.0.v20060603.jar [21] was not resolved.

Из строки Причина: отсутствует ограничение: Bundle-RequiredExecutionEnvironment: CDC-1.0 / Foundation-1.0, J2SE-1.3, я понимаю, что у него есть какой-то конфликт версий с J2SE, но журнал правильно показывает мою текущую версию Java, поэтому я не уверен, что проблема вообще.

Помощь будет оценена.

 pojo-guy15 окт. 2018 г., 17:47
Кажется, это происходит при каждом обновлении JVM. Просто была та же проблема с экземпляром eclipse, который мне нужно было запустить под 1.7, но у меня была установлена 1.9, и она не удалась. Принятый ответ дал мне то, что мне нужно, чтобы пройти через это.

Ответы на вопрос(3)

загрузив старую версию JDK 1.4, настроив переменную PATH для локальных переменных и добавив новый путь кC:\j2sdk1.4.2_19\bin, Это работает после перезапуска затмения.

ДОРОЖКА вstartAnOldEclipse.bat файл так, чтобы PATH указывал на каталог jre bin для версии jre, требуемой для этой версии Eclipse. Этот путь также содержит достаточно вещей для Windows, например, я

set PATH=<tool suite="" stuff="">;c:\j2sdk1.4.2_19\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem
</tool>

Я предполагаю, что ваше затмение перестало работать, потому что была установлена новая JRE, а переменная PATH была изменена, чтобы указывать на новую JRE.

В моем случаенабор инструментов был кросс-компилятором gcc, который был упакован со старым затмением.

Другой способ указать конкретную JRE:это говорит:Наиболее рекомендуемый способ указать JVM для запуска в Eclipse - это поместить конфигурацию запуска в eclipse.ini ».

 pojo-guy15 окт. 2018 г., 17:46
Это неЭто не влияет на виртуальную машину, используемую модулем запуска, что здесь не работает. Вы можете указать в командной строке в командном файле или ярлыке, однако
Решение Вопроса

старый версия Eclipse сновый JRE. Я выиграл'не могу понять, как и почемуc:\j2sdk1.4.2_19 содержит Java 7 JRE, но либо обновите свой Eclipse, либо вернитесь к использованию фактической версии 1.4 JRE.

 l46kok13 нояб. 2012 г., 06:25
Тот'Это странно, потому что папка содержит версию 1.4.2, а не 1.7.0. Я'Я не уверен, почему этоделает это Я'Я буду расследовать это.

Ваш ответ на вопрос