Установлены новейшие инструменты ADT и SDK, но все еще запрашиваются новейшие инструменты SDK [дубликат]

На этот вопрос уже есть ответ здесь:

Требуется версия Android ADT 20.0.0 и выше 10 ответов

Я только что установил Eclipse Juno и установил плагин ADT 20.0.3, но я все еще получаю это сообщение при каждом запуске Eclipse, говоря:Эта версия ADT требует Android SDK инструментов в версии 20.0.0 или выше. Текущая версия 18.0.0. Пожалуйста, обновите SDK до последней версии "Инструменты SDK, на которые я указывал в настройках, актуальны, потому что завтра я работал над Eclipse Indigo (на котором также был установлен ADT 20.0.3) и обновил все инструменты SDK. Я только что указал ту же папку SDK в Juno. помогите спасибо

 Gabriel Netto04 нояб. 2012 г., 17:48
Иногда проще просто настроить другую версию Eclipse.
 Cheeta04 нояб. 2012 г., 18:48
на индиго и юноне установлена последняя версия adt (v. 20.0.3)
 Gabriel Netto04 нояб. 2012 г., 18:58
Если вы говорите, что adt обновлен, а инструменты SDK обновлены, тогда игнорируйте сообщения, все должно работать нормально. Когда вы открываете android sdk manager из eclipse, он говорит, что он обновлен? Если это так, как я сказал, просто игнорируйте это.
 Cheeta04 нояб. 2012 г., 18:33
Оказывается, индиго дает мне ту же ошибку, что и выше. Что это сейчас?даже не трогай это.
 Cheeta04 нояб. 2012 г., 19:02
ну, я могу, но когда я создаю новый проект Android, он говорит, что инструменты SDK устарели, и вам нужно обновить их. Я неНе понимаю, вчера я создал новые проекты для Android, и все было хорошо. Теперь оба не работают!не имеет никакого смысла. По крайней мере Индиго должно работать
 Gabriel Netto04 нояб. 2012 г., 18:00
Только что сказал, получите чистую версию затмения, которое вы хотите использовать, и настройте его с самого начала. Иногда предпочтения в затмении нарушаются.
 Gabriel Netto04 нояб. 2012 г., 18:39
Я предполагаю, что ваша версия adt, установленная как плагин в eclipse, должна быть обновлена. Перейдите, чтобы проверить обновления в Eclipse и посмотреть, есть ли у ADT новая версия.
 Gabriel Netto04 нояб. 2012 г., 18:21
Затмение не делаетт действительно установить. Он просто создает конфигурацию в рабочей области и по пути, по которому вы разархивировали. Они неТ конфликтуют друг с другом либо. У меня есть как минимум 4 затмения, настроенные здесь для разных целей. Но если ваша юнона работает и будет придерживаться этого, то этим я сейчас и пользуюсь.
 Cheeta04 нояб. 2012 г., 17:57
Мне жаль, что я неЯ не должен использовать эту последнюю версию Juno?
 Cheeta04 нояб. 2012 г., 18:14
Хорошо, это был бы план B :). Возможно ли, что, поскольку у меня есть две установки затмения в системе, они конфликтуют каким-либо образом?. Установка с начала заняла бы целый день, потому что моя сеть медленная в эти дни. :(

Ответы на вопрос(4)

У меня также была эта проблема, за исключением того, что я получал ее для ADT 21, и сообщение было следующим: "

Эта версия ADT требует Android SDK инструментов ревизии 21.0.0 RC9 или выше ".

Мне не удалось выполнить обновление до SDK tools 21.0.0 RC9 с помощью SDK Manager. Я обнаружил, что мне пришлось переустановить SDK Tools для Windows, загрузивinstaller_r1-windows.exe

Я нашел эту ссылку наПолучить Android SDK стр.

После установки этого приложения мой SDK Manager показал, что SDK Tools 21 установлен, и дал мне возможность загрузить платформу Android 4.2.

На самом деле, решение не требует удаления или загрузки всего установщика. После обновления Eclipse ADT вам просто нужно обновить инструменты SDK в менеджере SDK. Хитрость в том, что открытый менеджер SDK -> Меню пакетов -> Обновить. Тогда последняя версия будет доступна для обновления. Это'Это так просто, но на самом деле раздражает на первый взгляд.

 dmon22 янв. 2013 г., 17:45
Вопрос в том, почему нетт это "Обновить» по умолчанию! Вздох.
 Jerry Brady09 янв. 2013 г., 17:24
Пожалуйста, примите этот ответ, потому что у меня была та же проблема, и яя знаком с запуском менеджера SDK из Eclipse, но пропустилОбновить» шаг.

У меня была такая же проблема,

перейти к C: // -> Программные файлы -> Android

Там должна быть только одна папка, у меня было более одной (из предыдущих загрузок SDK).

Затмение сбито с толку и использует не тот. Удалите устаревшие папки, сохраните самую последнюю загрузку SDK.

Перезапустите Eclipse, должно появиться сообщение об ошибке:найти свою папку SDK. Это даст вам кнопку с надписью "предпочтения» в этой ошибке. Зайдите в настройки и настройте путь к единственной папке, найденной в программных файлах -> андроид.

Хотя я установил параметры прокси в настройках сети Eclipse, они не былиИспользуется менеджером SDK. Менеджер SDK имеет свой собственный под "Инструменты -> Опции", Было бы здорово, если бы в будущих версиях вместо этого использовались настройки прокси-сервера Eclipse по умолчанию, чтобы избежать этой проблемы.

Ваш ответ на вопрос