доступно, что делает вашу существующую программу, изначально скомпилированную для более старой PostgreSQL, счастливой.

обновления Postgresql 8.1 до 9.0 я заметил проблемы с зависимостью библиотек. Postgresql отлично работает (соединение, запросы).

yum list postgresql*
Installed Packages
postgresql.i386 9.0.0-1PGDG.el5 installed
postgresql-debuginfo.i386 9.0.0-1PGDG.el5 installed
postgresql-devel.i386 9.0.0-1PGDG.el5 installed
postgresql-libs.i386 9.0.0-1PGDG.el5 installed
postgresql-odbcng.i386 0.90.101-2.el5 installed
postgresql-plruby.i386 0.5.1-5.el5 installed
postgresql-server.i386 9.0.0-1PGDG.el5 install

но когда я пытаюсь установить 'pg' для ruby, я получил

gem install pg
Building native extensions.  This could take a while...
ERROR:  Error installing pg:
        ERROR: Failed to build gem native extension.

/usr/local/bin/ruby extconf.rb
checking for pg_config... no
checking for libpq-fe.h... no
Can't find the 'libpq-fe.h header
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

При попытке с другим драйвером ruby-postgres, я получил

yum install ruby-postgres
ruby-postgres-0.7.1-5.el5.i386 from epel has depsolving problems
  --> Missing Dependency: libpq.so.4 is needed by package ruby-postgres-0.7.1-5.el5.i386 (epel)

а также

locate libpq.so.4
/usr/lib/libpq.so.4
/usr/lib/libpq.so.4.1

также экспортируемый путь

LD_LIBRARY_PATH=/usr/pgsql-9.0/lib
export LD_LIBRARY_PATH

после запуска сценария ruby ​​с «require pg» (работает на 8.1), я получил:

/usr/local/lib/ruby/site_ruby/1.8/i686-linux/pg_ext.so: libpq.so.4: cannot open shared object file: No such file or directory - /usr/local/lib/ruby/site_ruby/1.8/i686-linux/pg_ext.so (LoadError)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
        from /usr/local/lib/ruby/site_ruby/1.8/pg.rb:12
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'

Любые предложения, что делать больше?

Ответы на вопрос(5)

используя установку MacPorts Postgres 9, у меня работала следующая команда:

gem install pg -- --with-pgsql-lib=/opt/local/lib/postgresql90/lib --with-pg-config=/opt/local/lib/postgresql90/bin/pg_config

которые вы можете добавить к установке gem, например:-with-opt-dir, --with-pg-dir а также--with-pg-config, Посмотрите на эту ветку списка рассылки:

http://www.ruby-forum.com/topic/409608

 objah16 янв. 2011 г., 20:16
gem install pg - --with-pgsql-lib = / usr / pgsql-9.0 / lib --with-pg-config = / usr / pgsql-9.0 / bin / pg_config, она решает установку pg, спасибо! Но после запуска скриптов у меня пропал libpq.so.4 ...
 Michael Kohl19 янв. 2011 г., 20:57
Есть ли успехи в этом? Может быть, обновить ваш вопрос, чтобы мы могли лучше помочь вам?

libpq.so.4 из более старой версии PostgreSQL; 9.0 кораблей с/usr/pgsql-9.0/lib/libpq.so.5

Если у вас есть программа, созданная на основе libpq.so.4, этот файл предоставляетсяCompat-ЛИЭС для PostgreSQL пакеты, которые вы, возможно, не установили. Многие люди удаляют его, используя «--force», потому что иначе может быть сложно установить более новые RPM; это плохая идея, но альтернативасложный, Если вы установили этот пакет, вы должны найти/usr/lib/libpq.so.4 доступно, что делает вашу существующую программу, изначально скомпилированную для более старой PostgreSQL, счастливой.

$ gem --version
1.3.7

$ ruby --version
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-linux]

$ cat /etc/redhat-release 
CentOS release 5.4 (Final)

$ uname -m
x86_64

sudo yum list installed | grep postgre    (see what you have installed)
sudo yum list available | grep postgre    (I was missing postgresql-devel)
sudo yum install postgresql-devel         (I installed it)
sudo gem install pg                       (no error this time!)

$ gem list --local | grep pg
pg (0.11.0)
 krukid12 апр. 2012 г., 01:08
У меня был такой же сценарий при попытке установитьpg жемчужина на CentOS с уже существующимpostgres монтаж. Я подозреваю, что проблема в том, чтоpg_config не может быть найден, так как у меня его вообще не было в моей системе. После установкиpostgresql-devel a pg_config был добавлен иpg гем успешно установлен.

gem install pg -- --with-pgsql-lib=/usr/pgsql-9.0/lib --with-pg-config=/usr/pgsql-9.1/bin/pg_config

решает это !!

gem install pg -- --with-pgsql-lib=/usr/pgsql-9.0/lib --with-pg-config=/usr/pgsql-9.1/bin/pg_config

/usr/local/lib/ruby/1.9.1/yaml.rb:56:in `<top (required)>':
It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.
Building native extensions.  This could take a while...
Successfully installed pg-0.14.0
1 gem installed
Installing ri documentation for pg-0.14.0...
Installing RDoc documentation for pg-0.14.0...
 Ramfjord26 мар. 2015 г., 01:38
вы, вероятно, имели в виду совпадение версий pgsql-9.X

Ваш ответ на вопрос