ничего не изменил, все еще получаю

сьrvm use . чтобы следовать инструкциямздесь при попытке исправить испорченную конфигурацию я получаю следующее сообщение в консоли:

Неизвестная версия интерпретатора ruby ​​(не знаю, как обращаться): RUBY_VERSION. Не удалось определить, какой Ruby использовать; , должен содержать .rvmrc или .versions.conf или .ruby-version или .rbfu-version или .rbenv-version или соответствующую строку в Gemfile.

Что, я думаю, относится к переменной RUBY_VERSION в Gemfile:

source "https://rubygems.org" 
ruby RUBY_VERSION

Что я должен делать? Я полагаюRUBY_VERSION переменная должна быть определена как системная переменная?

Я просто пытаюсь использовать Джекилла.

Дополнительная информация:

Теперь у меня есть:

gem -v 2.6.14ruby -v ruby 2.0.0p648 (2015-12-16, редакция 53162) [universal.x86_64-darwin15]jekyll -v терпит неудачу с очень длинной ошибкой.bundle -v Bundler версия 1.14.4
 Alvaro31 окт. 2017 г., 17:41
@Cyzanfar используетrvm use 2.2.0 возвращаетсяRequired ruby-2.2.0 is not installed. To install do: 'rvm install "ruby-2.2.0"'
 Alvaro31 окт. 2017 г., 17:12
Я сделал, теперь я получаюRequired ruby-2.2.0 is not installed.даже при использованииruby -v возвращает меня:ruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin15]
 Alvaro31 окт. 2017 г., 17:43
Я добавил дополнительную информацию в вопросе.
 Cyzanfar31 окт. 2017 г., 17:14
rvm use 2.2.0 теперь версия ruby ​​должна быть версией должна быть установлена ​​на эту версию
 Cyzanfar31 окт. 2017 г., 15:32
Попробуйте добавитьruby '2.2.0' в ваш gemfile (заменив RUBY_VERSION на актуальную версию). Дайте мне знать, что вы получите тогда, когда вы пытаетесьbundle install

Ответы на вопрос(1)

Решение Вопроса

2.4.2' (с кавычками).

Однако, если вам не особо важно, какую версию Ruby вы используете, вы сможете просто удалить всю строку, и rvm будет использовать значение по умолчанию.

 Alvaro31 окт. 2017 г., 17:14
И использование числа, такого как 'ruby 2.0.0', показывает мне:Required ruby-2.2.0 is not installed. etc.... хотя с использованиемruby -v возвращаетсяruby 2.0.0p648 (2015-12-16 revision 53162) [universal.x86_64-darwin15]
 Alvaro31 окт. 2017 г., 17:40
Используя всю строку2.0.0p648 ничего не изменил, все еще получаюRequired ruby-2.0.0p648 is not installed. Could not determine which Ruby to use; . should contain .rvmrc or .versions.conf or .ruby-version or .rbfu-version or .rbenv-version, or an appropriate line in Gemfile.
 Alvaro31 окт. 2017 г., 17:14
Я попробовал оба. Удаление этого не будет работать, как говорится:Now using system ruby. Could not determine which Ruby to use; . should contain .rvmrc or .versions.conf or .ruby-version or .rbfu-version or .rbenv-version, or an appropriate line in Gemfile. Runrvm help` для просмотра информации об использовании
 Alvaro31 окт. 2017 г., 17:38
Оба сделано, сrvm --default use system Я получил сообщение «Сейчас использую системный рубин». дважды. Но ничего не изменилось.
 Floppy31 окт. 2017 г., 17:17
Несколько вещей, чтобы попробовать:rvm --default use system чтобы убедиться, что у rvm хороший запасной вариант, попробуйте установить в файле строку полной версии '2.0.0p648'.

Ваш ответ на вопрос