Windows Phone 8 Silverlight (УСТАРЕЛО)

обновления до последних версий XCode и Xamarin при сборке в Visual Studio я больше не могу ориентироваться на устройства iOS старше 11 лет. Что случилось?

 Bright Lee06 нояб. 2017 г., 08:55
@ Fritz Никогда не думал об этом. Я думал, что минимальная версия в плагине не имеет значения, и она следовала бы настройке моего проекта.
 fritz05 нояб. 2017 г., 13:55
@Bright Lee: Да, совершенно разные вещи, но почему плагин Xamarin для VS всегда устанавливает MinimumOSVersion в info.plist на последнюю версию SDK?
 Bright Lee28 сент. 2017 г., 23:02
Почему вы заботитесь об этом? Использование SDK отличается минимальной поддержкой версии ОС.
 Paul Kertscher29 сент. 2017 г., 08:30

Ответы на вопрос(1)

Решение Вопроса

вам нужно будет использовать Xcode 8, настроив Apple SDK Xamarin так, чтобы он указывал на копию Xcode 8.

Теперь черезDeployment Target В Info.plist вы можете контролировать минимальную версию iOS, с которой вы хотите запускать ваше приложение.

Параметр «Цель развертывания» используется для выбора минимально необходимой версии операционной системы, в которой будет работать ваше приложение. Это установлено в файле Info.plist вашего проекта. Вы должны выбрать минимальную версию, в которой есть все API, необходимые для запуска приложения.

Для форм на основеXamarin.iOS Вы не хотите устанавливать мин. меньше, чем iOS 8

Приложения Xamarin.Forms могут быть написаны для следующих операционных систем:

iOS 8 или вышеAndroid 4.0.3 (API 15) или выше (подробнее)Windows 10 Универсальная платформа Windows (подробнее)Windows 8.1 / Windows Phone 8.1 WinRT (подробнее)Windows Phone 8 Silverlight (УСТАРЕЛО)

Ваш ответ на вопрос