будет работать отлично

кто-нибудь сказать мне, почему мое приложение не устанавливается вообще и заканчивается сообщением об ошибке

Связь с обсерваторией так и не стала готова.

приложение работало отлично до вчерашнего дня.

Я изменил канал на master вчера в командной строке, и с тех пор приложение никогда не запускается.

Я даже переключился обратно на канал альфа, но все равно бесполезно.

Я приложил скриншот командной строки, где установка застряла навсегда.

Я не уверен, если мне нужно переустановить флаттер. Я волнуюсь, если я удалю флаттер сейчас, он может не настроить должным образом, и я могу сломать его навсегда.

Пожалуйста, может кто-нибудь сказать мне, что именно могло пойти не так.

Большое спасибо, Махи

Снимок экрана командной строки

Ответы на вопрос(4)

Решение Вопроса

Большое спасибо за ваш ответ @ Майкл Томсен.

Я попробовал то, что вы предложили, и детали заключаются в следующем:

Когда я использовалflutter run -v команда вывод командной строки выглядит следующим образом: он застрял на некоторое время вwaiting for port connection если я не ошибаюсь

Итак, я использовалAndroidStudio, File>Open и выбралandroid/ папка для запуска приложения, а затемgradle показывал ошибку:

Error:Conflict with dependency 'com.android.support:support-annotations' in project ':app'. Resolved versions for app (25.2.0) and test app (25.4.0) differ. See http://g.co/androidstudio/app-test-app-conflict for details.

Я модифицировалbuild.gradle(Модуль: приложение), чтобы показать правильную версию 25.2.0, которая ранее показывала 25.4.0.

 dependencies {
  androidTestCompile 'com.android.support:support-annotations:25.2.0'
  }

Я только что сохранил изменения в андроид студии и синхронизацию завершена без ошибок.

Теперь я могу запустить приложение из Android Studio, а также из IntelliJ IDE.

Большое спасибо, Майкл, это решило мою проблему.

$ echo $ PATH будет выглядеть так: / usr / local / bin: / usr / bin: / bin: / usr / sbin: / sbin: это означает, что вам нужно добавить флаттер в путь

Открыть Finder нажимает команду + Shift + G

Поместите / etc / paths в диалог и нажмите GO

Скопируйте файл "пути" и вставьте его на рабочий стол

Затем откройте вставленный файл «путей» с рабочего стола и добавьте следующую строку в конец файла «/ flutter / bin»

Затем скопируйте этот файл и снова вставьте его в / etc / paths, как в шаге 2

он попросит вас заменить или нет

нажмите заменить

Теперь, если вы нажмете $ echo $ PATH на терминале, он покажет / usr / local / bin: / usr / bin: / bin: / usr / sbin: / sbin: / Users / swagat / development / flutter / bin

Теперь ваш$ флаттер доктор будет работать отлично

Установить переменную пути: с помощью следующей команды терминала

export PATH=~/flutter/bin:$PATH;

это путь к папке с мусором флаттера.

   export PATH=[PATH_TO_FLUTTER_GIT_FOLDER]/bin:$PATH

https://flutter.io/setup-macos/#update-your-path

Если выше не сработало. Проверьте с версией Dart

dart --version

Установите последнюю версию дартс:

    brew install dart --devel

Надеюсь, что это помогает другим.

устранена, пожалуйста, опубликуйте вывод$>flutter doctor и описание того, что именно приводит к этой ошибке.

 Mahi26 сент. 2017 г., 14:09
Я знаю, что довольно сложно ответить на вопрос без точных подробностей, но спасибо за вашу помощь @Rainer Wittman. К сожалению, я застрял и, возможно, придется потратить день или два, чтобы понять, что пошло не так? Я пытался клонировать код, и он, кажется, работает нормально на других системах, но не работает на моем ноутбуке.
 Rainer Wittmann26 сент. 2017 г., 14:29
Вы можете отредактировать свой вопрос, чтобы добавить флаттера доктора.
 Mahi26 сент. 2017 г., 13:57
Спасибо, Райнер, я попытался переустановить флаттер путем клонирования из git, но безрезультатно, что он не выдает никакого сообщения об ошибке, но застревает, как на предыдущем снимке экрана, который я опубликовал с вопросом. Мне жаль, что я не смог опубликовать вывод доктора флаттера, так как символы превышают лимит для добавления в комментарии

Ваш ответ на вопрос