решил проблему для меня, но я все еще получаю предупреждения. Попробуйте чистую сборку: команда + Shift + B

алось загрузить предупреждение OMO (возможный сбой):

Проект с xcode 9 после предупреждения наблюдается в консоли во время сборки отладки / выпуска (iOS 11 GM / beta и iOS 10):

CoreData: annotation:  Failed to load optimized model at path "/Users/xyz.abc/Library/Developer/CoreSimulator/Devices/A-GUID/data/Containers/Bundle/Application/B-GUID/app-name.app/Frameworks/framework-name/mystorename.momd/mystorename 6.omo"

Любая пользовательская среда (например, GoogleMaps и т. Д.), Использующая CD, также приводит к этому предупреждению и потенциальным сбоям.

Обновление: Использование Xcode версии 9.1 бета (9B46) не приводит к этому предупреждению.Примечание:Также заметил это с модальным, используемым вприложение и другие рамки. Для приложения очистите результаты сборки в этой ошибке. Путь в предупреждениях указывает на модель, используемую с приложением, а не с фреймворком.Компиляция с предыдущим Xcode работает нормально, и никаких предупреждений не замечено.Пробовал следующее:полная чистая сборкаесли в datamodel v6 существует omo, ManagedObjectModel и PersistentStoreCoordinator не равны нулю. Весь функционал работает как положено.добавьте более новую версию datamodel v7, гарантируя, что omo v7 существует - чистые сборки и развертывание устройстваснова добавил схему

Пожалуйста, добавьте предложения. Каковы потенциальные последствия этого предупреждения?

Связанный:https://openradar.appspot.com/33212613https://openradar.appspot.com/33573724https://openradar.appspot.com/33773917https://issuetracker.google.com/issues/35827124https://issuetracker.google.com/issues/35827113Аналогичные проблемы со старым Xcode 6 / iOS 9 и Xcode 7 / iOS 9Базовые данные - не удалось загрузить оптимизированную модель по путиCoreData: не удалось загрузить оптимизированную модель по путиПредупреждение Google Maps SDK для iOS во время выполнения - не удалось загрузить базовую дату по оптимизированному пути
 DaNLtR22 сент. 2017 г., 20:37
Эй, тебе удалось это исправить?
 lal24 сент. 2017 г., 00:18
@DaNLtR, пока нет. Я еще не наблюдал сбоев, планирую вернуться к нему через несколько дней.
 mijokaliger11 янв. 2019 г., 09:55
Проверьте этоответ на связанный вопрос.
 DaNLtR24 сент. 2017 г., 09:01
tnx :) googleMaps SDk вылетает из строя мое приложение ios 11 без причины!
 Dave Reed25 сент. 2017 г., 17:04
Я видел это предупреждение в выходные дни, когда выполнял некоторую работу над моим приложением для его обновления (текущая версия работает на iOS 11, но я хотел начать удалять некоторые предупреждения об устаревании, так как приложение изначально было написано для iOS 5). Когда я сегодня использовал это приложение, оно зависало при попытке открыть один из моих основных файлов данных. У меня была резервная копия файла основных данных (приложение создает резервные копии), и я смог открыть его. Надеюсь, Apple скоро это исправит. Рад, что я не сделал обновления в App Store!

Ответы на вопрос(3)

ие в консоль. Попробовал следующее воспроизвести консольное сообщение:

Чистые стручки целиком и перестроенный проект.Полная очистка Xcode, включая производные данные, очистка симулятора.Развертывание устройства, сбоев не наблюдается.
 lal31 окт. 2017 г., 21:21
Обновил ответ. Да, нет никакого предупреждения с 9.1 (9B46) бета.
 DJ-Glock31 окт. 2017 г., 10:08
Ты имеешь в виду, что с Beta нет предупреждения?
 DJ-Glock01 нояб. 2017 г., 05:17
:( У меня была такая же проблема с версией 9B46
 DJ-Glock02 нояб. 2017 г., 07:42
Это, очевидно, мое приложение, потому что ошибка связана с моей моделью данных, новой версией модели.
 Greg Robertson09 нояб. 2017 г., 22:07
Получение ошибки и сбой с 9B55. У меня есть версионная модель и я добавил новую версию, но по-прежнему получаю предупреждение о сбое и консоли на устройстве, а также не выдает предупреждения консоли на симуляторах

Вот трекер проблем:Сбои на iOS 11

просто обновите свой Podfile

pod 'GoogleMaps'
pod 'GooglePlaces'

И под обновление

Я получал эти предупреждения на симуляторе, после возврата модуля «GoogleMaps» в 2.2, API больше не отображал карту. Я обновил до 2.5, который только что получил релизы, карта работает, но я все еще получаю эти журналы.

Также попробуйте чистую сборку! Мое приложение неожиданно начинало зависать, когда я открывал контроллер с импортированными в него GoogleMaps, и все было абсолютно нормально, поэтому я потратил часы и, наконец, просто сделал чистую сборку, и проблема была решена!

command + shift + B
 turingtested05 дек. 2017 г., 14:14
GoogleMaps 2.5.0 не решил проблему.
 Ramin05 дек. 2017 г., 18:37
решил проблему для меня, но я все еще получаю предупреждения. Попробуйте чистую сборку: команда + Shift + B

а не только предупреждение) - понизить ваш SDK!

В вашем Podfile измените следующие строки:

pod 'GoogleMaps', '2.2'
pod 'GooglePlaces', '2.2'

После этого запуститеpod update поэтому библиотека будет обновлена.
любая версия выше это вылетит.

 lal25 окт. 2017 г., 14:56
Также получим это на других платформах (не GoogleMap) и с чистым встроенным кодом приложения. В записанном предупреждении есть путь, указывающий на модель, используемую с приложением.

Ваш ответ на вопрос