jquery.mobile 1.4.5 Uncaught TypeError: Невозможно прочитать свойство concat из неопределенного

Я создал образец файла index.html и включил последнюю версию jquery (3.1.0) и jquery mobile (1.4.5).

На странице загрузки выдается консоль ошибок:

jquery.mobile-1.4.5.js:3337 Uncaught TypeError: Cannot read property 'concat' of undefined

на этой линии:

mouseEventProps = $.event.props.concat( mouseHookProps ),

Когда я попытался включить JQuery-1.11.2 не было никаких проблем. Кто-нибудь может сказать мне, почему? Заранее спасибо.

 Tushar21 июл. 2016 г., 09:12
Проверить, еслиjquery3 совместим сjquery.mobile1.4.5

Ответы на вопрос(3)

http://www.way2tutorial.com/jquery/jquery_download.php , используйте эту ссылку, чтобы загрузить последнюю версию jquery ... это решит эту проблему

Решение Вопроса

Смотри эту документацию

Мобильный jQuery заблокирован для некоторых версий jQuery! Вы найдете текст

jQuery Mobile 1.3.0 поддерживает версии ядра jQuery 1.7.2 - 1.9.1, и мы также активно тестируем новую версию 2.0. Мы будем синхронизироваться с их выпусками, чтобы вы могли в полной мере воспользоваться новым совершенством.

ОБНОВИТЬ

jQuery mobile теперь работает и с версиями 2.x, хотя версия 3 по-прежнему возвращает указанную ошибку.

 dsghi25 сент. 2017 г., 05:36
Я извиняюсь, я не могу вспомнить, какие шаги я предпринял - урок усвоен, я не буду публиковать комментарии без использования в будущем. : /
 dsghi08 февр. 2017 г., 11:12
С использованиемПлагин jQuery Migrate решает это красиво.
 Richard Griffiths09 февр. 2017 г., 11:26
Как ты заставляешь это делать работу?
 markj13 сент. 2017 г., 15:24
@dsghi Я загрузил jquery-migrate-1.4.1.min.js на свой веб-сайт, но это не решило проблему. Ошибка все еще там. И я позаботился о том, чтобы загрузить файл jquery-migrate выше JS-файла jquery-mobile.
 pat capozzi19 дек. 2017 г., 20:45
Плагин Jquery Migrate работал и для меня
== Решение ==

использовать последнюю версию1,5 (Доступно только по адресу:code.jquery.com ):

http://code.jquery.com/mobile/1.5.0-alpha.1/jquery.mobile-1.5.0-alpha.1.min.js

(благодаряPF4Public)

 yasriady12 мая 2018 г., 03:43
этот ответ работает от меня. Я использую 1.5.0-alpha вместо 1.4.5
 que132608 мар. 2019 г., 12:53
рип jQuery мобильный 2019, недурно, пожалуйста!
 T.Todua08 мар. 2019 г., 14:23
@ que1326 это прекращено? я не видел никаких новостей
 Wilson Rosa Gomes12 янв. 2019 г., 12:08
Coloquei esta versão 1.5 e решает проблему. Я поставил эту версию 1.5 и решил мою проблему.

Ваш ответ на вопрос