Не удалось построить модуль Objective C 'JSQMessagesViewController'

У меня есть два проекта, которые оба используют JSQMessagesViewController, однако в одном из них я получаю сообщение об ошибке: «Не удалось построить модуль Objective C« JSQMessagesViewController »», тогда как другой работает нормально ... Между этими двумя практически нет различий проекты, как мне заставить JSQMessagesViewController работать, потому что это важно для моего приложения. Благодарю.

 Umair Afzal28 июн. 2016 г., 14:40
ты следовал этим инструкциям?developer.apple.com/library/ios/documentation/Swift/Conceptual/...
 Ahad Sheriff28 июн. 2016 г., 14:44
Да, но я думал, что cocoapods справится с этим в бэкэнде, я имею в виду, что он работал с другими фреймворками, такими как firebase и crashlytics ...
 Ahad Sheriff28 июн. 2016 г., 14:42
Я не следовал за этим ... Я просто использовал какао-бобы для установки необходимых зависимостей. Все остальные фреймворки работают, кроме этой конкретной.
 Umair Afzal28 июн. 2016 г., 14:43
Вы хотите использовать объективный модуль в Swift правильно?

Ответы на вопрос(2)

попробуйте установить последнюю версию JSQMessagesViewController, которая сейчас разрабатывается через (модуль 'JSQMessagesViewController',: git => 'https://github.com/jessesquires/JSQMessagesViewController.git',: branch =>' Develop ') у меня это сработало ..

Решение Вопроса

Я исправил проблему, выполнив следующие шаги:

Очистить проект, включая кэш сборки (Command-Option-Shift-K)Удаление файла pod.lock и файлов pods.xcodeprojА потом закрываем Xcode и снова запускаем обновление podЗатем снова строим.
 Ivan01 нояб. 2018 г., 11:37
Вы, сэр, гениален!
 ShreePrakash17 мар. 2017 г., 15:57
@AhadSheriff У меня такая же проблема в Xcode 8, а мой код написан на Swift 2.3. Я попробовал в соответствии с вашим ответом, но не смог добиться успеха. Можете немного мне помочь.
 Jeeva07 дек. 2018 г., 09:18
Ты потрясающий чувак !!!
 Mattk9019 нояб. 2016 г., 00:49
Решил и мою проблему. Спасибо!
 Soft Dev18 апр. 2018 г., 20:20
Это решение не работает для меня также. Я интегрирую MSGraphSDK_NXOAuth2Adapter.
 Ahad Sheriff09 янв. 2017 г., 06:10
@AziCode Надеюсь, вы уже поняли, но я имел в виду только файл pods.xcodeproj
 justColbs02 сент. 2016 г., 17:16
Примечание: запуск Xcode 7.3.1 - Простая очистка проекта и включение кэша сборки решили проблему для меня!
 AziCode29 дек. 2016 г., 02:58
Когда вы говорите «удалить файлы pods.xcodeproj». Вы имеете в виду просто удалить файл pods.xcodeproj? или удалить его и все остальные файлы, расположенные в том же каталоге?
 Satish Mavani31 янв. 2019 г., 12:47
удаление файла .lock и .xcodeproj не повредит существующему проекту?
 Jason Rueckert22 авг. 2019 г., 15:35
Может показаться, что моя проблема была в том, что я обновил Cocoapods до 1.8.0.beta.1, потому что, вы знаете ... новенький. Возвращение к 1.7.5 вернуло меня к работе без ошибок.

Ваш ответ на вопрос