IntelliJ IDEA не может установить JDK

Я пытаюсь настроить JDK в IntelliJ IDEA, и что бы я ни делал, или какую бы версию JDK я ни выбрал, ничего не происходит. Сохраняется следующая ситуация: enter image description here

Поэтому я сказал IDEA, какой JDK он должен использовать, но он все равно просит меня настроить JDK. Это ошибка или я что-то упустил? Могу ли я применить любой обходной путь, чтобы все работало как обычно?

ADDITION

Шаги, которые я прохожу, настраивая JDK: Ситуация до настройки:
enter image description here

первый шаг:
enter image description here

второй шаг:
enter image description here

третий шаг:
enter image description here

Ситуация после настройки JDK: enter image description here

SDKs:
enter image description here

Настройки модуля:
enter image description here

 CrazyCoder16 мая 2012 г., 15:15
ПытатьсяFile | Invalidate Caches.
 Alex16 мая 2012 г., 09:20
Сделайте снимок из & quot; Project Structur & quot; - & GT; & quot; Настройки платформы & quot; - & GT; SDKs
 yair16 мая 2012 г., 08:52
Как ты сказал Интеллию? Добавьте несколько снимков.
 mr.nothing16 мая 2012 г., 09:15
@yair, спасибо за ответ, добавил способ, которым я настроил JDK для проекта.
 mr.nothing16 мая 2012 г., 09:24
@ Алекс, обновлено. Спасибо за ответ.

Ответы на вопрос(7)

Press F4 Select Modules in Project Settings Set up Module SDK from the drop down or add the new one. Apply & OK

кто, как я, ищет способ настроить автономную документацию в IDEA на UBUNTU Linux. Вам следует установить пакет openjdk-8-doc (или openjdk-X-doc в общем случае), а затем перейти кFile|Project Structure|SDKs|1.8(еще1.X в общем), затем выберите вкладкуDocumentation Paths и добавьте путь/usr/lib/jvm/java-1.8.0-openjdk-amd64/docs/api там.

Обратите внимание, что путь установки Java-документов на вашем компьютере может отличаться. Вы можете проверить путь выполнения установки Java docsdpkg-query -L openjdk-8-doc | less в оболочке.

NoClassDefFoundError: com/intellij/remote/RemoteSdkConnectionAcceptor

который был вызван плагином Python Community Edition для Intellij IDEA 2016.2.5.

После обновления / отключения плагина я смог снова установить SDK.

Выберите свой модуль в представлении проекта

Нажмите F4

Перейти в SDK

Выберите свой SDK

Убедитесь, что у вас есть различные банки там. В противном случае выберите правильный каталог.

В моем случае, хотя был выбран правильный каталог classpath, sourcepath и т. Д. Были пустыми.

Поэтому мне пришлось выбрать каталог установки jdk еще раз, который загрузил все jar-файлы и решил проблему.

Решение Вопроса

File | Invalidate Caches это первое, что вы должны попробовать в случае возникновения таких проблем.

 05 июл. 2018 г., 22:27
Это мне очень помогло, спасибо!
 15 апр. 2018 г., 09:42
Работал, достаточно просто ...
 07 сент. 2018 г., 01:39
Вы спасатель жизни ... Я думал, что сломал IDE! Компьютер был отключен из-за отключения питания, а затем я снова загрузил его до всех красных ошибок. Спасибо за это @CrazyCoder

Вид проекта & quot; и нажмите клавишу F4 в поле «Настройка проекта», выберите «Модуль». В разделе «Настройки модуля» Обзор вы можете добавить / удалить Modul SDK.

 01 июн. 2016 г., 17:40
Та же проблема, нет способа избавиться от древнего SDK 1.6 ...
 mr.nothing16 мая 2012 г., 08:37
Я пытался удалить все jdks и установить его с нуля, но, к сожалению, безрезультатно. (

File | Invalidate Caches а такжеRestart не работал. После щелчка правой кнопкой мыши на проекте и перехода кModule Settings , Я не выбрал SDK подProject Settings->Project.

Ваш ответ на вопрос