ADT 22.3 (android 4.4) - получение ошибки «После создания сцены должен быть вызван #init ()»

После установки нового ADT (22.3.0.v201310242005-887826), который поддерживает Android 4.4 (KitKat), я продолжаю получать сообщение об ошибке, как показано здесь:

Произошла внутренняя ошибка

В списке ошибок я вижу несколько элементов «RenderPreview», и когда я нажимаю на любую из них, я вижу:

Произошла внутренняя ошибка. После создания сцены необходимо вызвать #init ()

При тестировании нового ADT на другом компьютере я не вижу этой ошибки. Это очень странно.

Почему я получаю эти ошибки, и что я могу сделать, чтобы исправить это?

 android developer20 нояб. 2014 г., 08:54
@ZaferCelaloglu Я не знаю о классе Scene, но для поддержки более низких API, вам нужно установить "minSdkVersion" в манифесте. "targetSdkVersion" должен быть установлен на максимально доступный (который в настоящее время 21). Я предлагаю прочитать документацию:developer.android.com/guide/topics/manifest/...
 Guy03 нояб. 2013 г., 21:53
Точно такая же проблема, я просто тоже открылвопрос себя. Не видел ваш вопрос раньше.
 Zafer Celaloglu20 нояб. 2014 г., 07:57
Я также использую класс Scene в своем проекте (для начала перехода), но минимальная версия API 19, но я хочу поддерживать до 19 лет, как я могу это изменить?
 android developer03 нояб. 2013 г., 13:44
@DixieFlatline это хорошо. значит, я не сделал ничего плохого (на этот раз :))
 DixieFlatline03 нояб. 2013 г., 12:46
У меня такие же проблемы.

Ответы на вопрос(6)

Обходной путь: Переключитесь на Android-18 в графическом макете (зеленый Android вверху справа).

Ссылка: вопрос переполнения стекаКак исправить Eclipse ADT Plugin 22.3 / SDK Tools 22.3 с неработающим окном свойств?

но одно снижение до Android 4.3 (Jelly Bean) для меня сейчас только удачное временное решение.

 bruno.braga05 нояб. 2013 г., 02:47
то же самое здесь со мной.
 android developer04 нояб. 2013 г., 07:28
К сожалению, тот же компьютер также имеет другую проблему (с пользовательскими представлениями) в конструкторе пользовательского интерфейса, независимо от того, какой ADT он имеет. Я сообщил об этом здесь:stackoverflow.com/questions/18119907/...

Изображение Android в графическом макете.

это новый баг. Может быть, нам нужно подождать, пока Google обновит его.

который поддерживает Android 4.4 (kitkat), я получил такую же ошибку.

Затем установите версию API в предварительном просмотре пользовательского интерфейса на значение ниже 19. Ошибка отображается только для версии 19.

Решение Вопроса

сообщение об ошибке, Пока это не будет исправлено, установите версию API в предварительном просмотре пользовательского интерфейса на значение ниже 19. Ошибка появляется только для версии 19.

 andikurnia15 дек. 2013 г., 12:58
ах, спасибо за ваш ответ Сегодня получил эту ошибку после обновления в kitkat ... странно
 SimonSays30 дек. 2013 г., 20:19
Да, подтверждено. Последнее обновление SDK устраняет проблему.
 android developer22 дек. 2013 г., 14:30
Кажется, что эта ошибка была исправлена. Я обновил SDK (до 22,3? Я не уверен), и теперь он работает нормально.
 SimonSays25 нояб. 2013 г., 19:05
К вашему сведению: статус ошибки установлен на «исправлено», поэтому я думаю, что это будет частью следующего обновления ADT.
 android developer05 нояб. 2013 г., 22:56
странно, что на некоторых компьютерах это не происходит.

Ваш ответ на вопрос