Bundler не смог найти совместимые версии для gem «railties» для Rails 4.0.0

Я пытаюсь обновить до Rails 4.0.0, и я изменил версии gemsass-rails а такжеcoffee-rails, Мне нужно разрешить этот драгоценный конфликт междуrails а такжеcoffee-rails прежде чем я смогу обновить до Rails 4.

Когда я побежалbundle update это вывод, который я получил:

$ bundle update
Updating git://github.com/pilu/web-app-theme.git
Fetching source index from https://rubygems.org/
Resolving dependencies..............
Bundler could not find compatible versions for gem "railties":
  In Gemfile:
    rails (= 4.0.0) ruby depends on
      railties (= 4.0.0) ruby

    coffee-rails (= 4.0.0) ruby depends on
      railties (4.0.0.rc2)

Мой:Gemfile

source 'https://rubygems.org'

gem 'rails', '4.0.0'

gem 'cancan'
gem 'client_side_validations'
gem 'devise', '~> 1.5.3'
gem 'dynamic_form'
gem 'execjs'
gem 'haml'
gem 'httparty'
gem 'jquery-rails'
gem 'mysql2'
gem 'paperclip', '~> 2.4'
gem 'prawn'
gem 'rails3-jquery-autocomplete'
gem 'rake', '0.9.2'
gem 'remotipart', '~> 1.0'
gem 'simple_datatables'
gem 'therubyracer'
gem 'validates_timeliness', '~> 3.0.2'
gem 'will_paginate', '~> 3.0'

gem 'turbolinks'
gem 'jquery-turbolinks'

gem 'noty-rails'

gem 'font-awesome-rails'

gem 'socket.io-rails'

gem 'attr_encrypted'

gem 'bullet', :group => 'development'

#temp for demo.managetherapy.com
#gem 'faker'

group :test do
  gem 'capybara'
  gem 'cucumber-rails', :require => false
  gem 'database_cleaner'
  gem 'factory_girl_rails'
#  gem 'faker'
  gem 'guard-rspec'
  gem 'selenium-webdriver', '2.7.0'
  gem 'webrat'
end

group :development, :test do
  gem 'faker'
  gem 'haml-rails'
  gem 'hpricot'
  gem 'rspec-rails'
  gem 'ruby_parser'
  #gem 'web-app-theme', '~> 0.8.0'
  gem 'web-app-theme', :git =>'git://github.com/pilu/web-app-theme.git'
end

gem 'sass-rails', '4.0.0'
gem 'compass-rails', '1.0.3'
gem 'coffee-rails', '4.0.0'
gem 'uglifier', '>= 2.1.1'
gem 'bootstrap-sass-rails'

# Use unicorn as the web server
#gem 'unicorn'

# Deploy with Capistrano
gem 'capistrano'
gem 'rvm-capistrano'

gem 'passenger'

Ответы на вопрос(6)

bundle update позволяет обновлять только один гем за раз, что сложно, если вы обновляете доRails 4 и множество драгоценных камней должны быть обновлены одновременно.

Я решил это, удаливGemfile.lock и делать.bundle install

Это, конечно, при условии, что у вас нет конфликтующей явной версии гема в вашемGemfile начать с. Поэтому, если это не удастся, удалите номера версий из Gemfile.

 Luis Menjivar02 мая 2017 г., 03:34
Натанвда совет сделал трюк для меня. Спасибо!
 Michael Durrant17 авг. 2014 г., 21:26
У меня не получилось, я нашел ExReanimatorответ сработал для меня
 nathanvda18 авг. 2014 г., 10:24
Ну этот ответ не экстрасенс, у меня у вас есть явные версии в вашемGemfileи они конфликтуют, вам придется удалить явную версию гема. Я буду расширять свой ответ соответственно. Главное, для меня было удалитьGemfile.lockиначе я так и не смог обновить. Поэтому, если вы начали с ответа ExReanimators, он бы не работал, если вы не удалили Gemfile.lock. Но рад, что ты получил его на работу.
 Tu H.22 авг. 2013 г., 09:52
Это работает для меня. удалятьGemfile.lock и все так гладко, как в аду: D.
 Keenan Payne13 дек. 2013 г., 20:06
Круто, это сработало и для меня. Спасибо за чаевые!
 Jorge Sampayo07 сент. 2013 г., 15:52
Это сработало для меня: я должен добавить, что также, если один конкретный камень вызывает проблемы, измените ~> для>= (напр. драгоценный камень 'кофейные рельсы ',' ~> 4.0.0' для драгоценностикофейные рельсы ','>= 4.0.0 ') и следуйте инструкциям nathanvda
 nathanvda07 сент. 2013 г., 16:37
~> будет обновляться, но только на уровне исправления (в соответствии с semver: только нерушимые изменения). Изменение на>= обновится до последней версии (с учетом всех других зависимостей / ограничений) и на самом деле просто установит минимальную версию, которая необходима (с вашей стороны). Так что да: это, вероятно, наиболее определенно необходимо.

используйте Rails 4 совместимый

gem 'devise', '~> 3.0.0.rc'

Также изменитьcoffee-rails в

gem 'coffee-rails', '~> 4.0.0'

и попробуйте сделать

bundle update coffee-rails
УдалитьGemfile.lock файлобращатьсяВот для базовых изменений gemfileбежатьbundle install

gem update rails будет первыйbundle update

 Nadav B09 мар. 2018 г., 15:15
Должно ли обновление пакета автоматически обновлять гем рельсов, который находится в Gemfile? Есть ли необходимость запускать рельсы обновления gem вручную?

которые неt поддерживается Rails 4. Закомментируйте все гемы, кроме Rails 4, и раскомментируйте их по одному после запуска bundle install, чтобы найти виновных. Возможно, вам придется отменить некоторые из ваших версий блокировки.

уститеобновление пакета

Ваш ответ на вопрос