OpenSSL 1.0.1 на Heroku

Мое приложение работает на Ruby 2.0.0, построенном на OpenSSL 1.0.1c для поддержки AES-GCM. Heroku, похоже, использует OpenSSL 0.9.8k (см.https://twitter.com/sferik/status/314495375555829760). Есть ли способ обновить до 1.0.1?

Ответы на вопрос(1)

Решение Вопроса

Вам нужно создать версию Ruby, связанную с верной версией OpenSSL, которая будет работать на Heroku 'система Для этого вам нужно использовать либо локальную 64-битную систему Linux, либо сервер сборки Heroku. У Vulcan есть проблемы с сборкой Ruby, поэтому лучший способ сделать это при отсутствии подходящей локальной машины - это использоватьHeroku толчок из пустой директории с пакетом на основе исходного кода. Затем вы можете извлечь двоичные файлы из полученного слага и использовать их с гораздо более быстрым двоичным сборочным пакетом.I '

веразместил мой buildpack здесь, В настоящее время он работает и предоставляет Ruby 2.0.0 с OpenSSL 1.0.1e.

Ваш ответ на вопрос