CocoaPods - использовать конкретную версию pod

Я использую CocoaPods для приложения MacOS. У меня есть ошибки компиляции с AFNetworking (текущая версия, 1.2.1) и увидел, что это нене существует в предыдущей версии (1.2.0).

Я провел некоторое исследование, но не нашел возможности определить версию модуля (например, версию 1.2.0 вместо 1.2.1).

Возможно ли это, или я должен ждать, пока не появится новая версия этой библиотеки?

Ответы на вопрос(3)

Решение Вопроса

В вашем подфиле:

pod 'AFNetworking', '1.2.0'

Проверьте 'Начать' вhttp://cocoapods.org

 carbonr29 окт. 2013 г., 08:27
как можно сказать эту версию стручка и выше?
 nein.26 мая 2013 г., 12:28
Я уже попробовал это. Но он загружает самую последнюю версию.
 Marcel29 окт. 2013 г., 10:26
Смотрите документацию наcocoapods.org: '> 0.1 Любая версия выше 0.1>= 0.1 Версия 0.1 и любая более поздняя версия < 0,1 Любая версия ниже 0,1 <= 0.1 Версия 0.1 и любая более низкая версия ~> 0.1.2 Версия 0.1.2 и версии до 0.2, не включая 0.2 '

8,0', Он автоматически установит предыдущий, который будет работать на этой платформе

В своем подфайле напишите: pod 'podname ','желаемая версия ».

Запустите pod update или pod install (в зависимости от обстоятельств), чтобы получить модули, как указано в предыдущем шаге.

Скомпилируйте код с нужной версией модуля.

Ваш ответ на вопрос