Пример установки SmartWatch

Я хотел бы скомпилировать образец, предоставленный Sony для его SmartWatch. Я следовал инструкциям в этомстраница, Но когда я добавилSmartExtensionUtils Проект я видел много ошибок, таких как:com.sonyericsson.extras.liveware.aef cannot be resolved to a variable, Вместо этого импортаcom.sonyericsson.extras.liveware не имеет проблем. Кто-то нашел и решил эту проблему?

Ответы на вопрос(5)

Чтобы скомпилировать EightPuzzleGame, вам нужно добавить следующие библиотечные проекты, доступные в SDK:

SmartExtensionAPISmartExtensionUtilsSmartExtensionInternalUtils

В вашем случае, это, вероятно, отсутствует проект API. Вы можете увидеть, какие проекты библиотеки отсутствуют, проверив свойства проекта. Пример:

 Nicola15 мая 2013 г., 12:11
Следующая ссылка на мой скриншот рабочего стола. SmartExtensionAPI и утилиты находятся в списке проектов (слева), но EightPuzzleExtension не находит их!Скриншот
 Nicola04 июн. 2013 г., 16:33
Сейчас я'Я могу скомпилировать SEAPI и SEUtils, но два семпла по Sony еще не скомпилированы. У меня проблемы с файлом R.java. Некоторые методы класса R не существуют. Тогда я не могу найти проект SmartExtensionInternalUtils в SDK. Где это находится?

роект из существующего источника, установите флажок «Импортировать проект в рабочую область». Таким образом, EightPuzzle, SEAPI и SEUtils будут находиться в одном каталоге, и вы 'не будет никаких ошибок :)

чтобы решить эту проблему, так это сначала импортировал из образцов Sony в SDK-надстройке Sony 3.0 SmartExtensionAPI, а затем SmartExtensionUtils. Если эти образцы построены правильно, остальные образцы также будут построены правильно.

Перейдите в «Файл | Импорт», выберите SmartExtensionAPI в качестве корневого каталога и нажмите «Готово». Возможно, вам придется изменить уровень соответствия компилятора, чтобы правильно его построить. После этого сделайте то же самое для SmartExtensionUtils.

Этоссылка на сайт на мой рабочий стол. SmartExtensionAPI и утилиты находятся в списке проектов (слева), но EightPuzzleExtension не находит их

это перейти на страницу свойств библиотеки SmartExtensionUtils и в окне библиотеки добавить SmartExtensionAPI в качестве зависимости

Ваш ответ на вопрос