Можно ли использовать бета-версию .NET 4.0 в Visual Studio 2008?

В .NET 4.0 есть несколько действительно замечательных функций, которые я хотел бы начать использовать, но мне пока неудобно вносить изменения в VS 2010. Есть ли способ использовать бета-версию .NET 4.0 в VS 2008?

 Simon P Stevens30 июл. 2009 г., 22:29
Вы счастливы, используя .net 4.0бета но вы не довольны vs2010. Почему вы используете одну бета-версию, а другую нет? Лично ни то, ни другое не должно использоваться для живых приложений, пока они находятся в бета-версии.
 devios125 мая 2010 г., 01:48
@Simon: Когда-нибудь задумывались, может быть, не каждый может позволить себе последнее обновление Visual Studio? Лично я считаю, что это слабый MS требует от разработчиков обновления до своего последнего инструмента для разработки для последней версии фреймворка.
 Peter Mortensen22 июл. 2015 г., 21:26

Ответы на вопрос(5)

опция Multi Targeting VS 2008 поддерживает только .NetFramework 3.5, 3.0, 2.0

поэтому он имеет обратную совместимость, поэтому вы должны использовать VS 2010 для .netFramework 4.0

Но если вы хотите ознакомиться с некоторыми функциями .net 4, вы можете загрузить уже устаревшую версию.Параллельные исключения CTP и попробуйте это с Visual Studio 2008.

Это не так много ...

это невозможно, .NET 4.0 требует VS 2010, чтобы иметь возможность целевого использования / сборки.

некоторые новые продукты, которые будут поставляться с 4.0, были выпущены как «расширения» и «CTP».Расширения Parallels для .NET 3.5 в конечном итоге будет включен в 4.0, но вы можете начать играть с ним сейчас в VS 2008.

 zvolkov31 июл. 2009 г., 16:43
@Simon P Stevens Спасибо, вы можете привести пример?
 Simon P Stevens30 июл. 2009 г., 22:32
Обязательно попробуйте, но учтите, что между параллельными расширениями для 3.5 и библиотекой задач в 4.0 есть некоторые существенные различия.

что это так - среда IDE обычно привязана к определенной версии платформы, и 2008 была первой версией, которая позволила вам ориентироваться на «не родную» (так сказать) версию платформы, вместо только соответствующей версии.

Хотя Microsoft могла бы добавить поддержку позже, я бы не ожидал, что это произойдет, хотя я ожидаю, что 2010 год сможет ориентироваться на разные версии, кроме 4.0 (я не использовал его, поэтому он может сделать это, и я не знаю этого) ). Обновить:Согласно этому, Цели 2010, 2, 3, 3.5 и 4.

Для достижения цели 4.0 вам придется использовать 2010 год - по крайней мере, на данный момент и, возможно, на неопределенный срок.

 Steven24 февр. 2010 г., 12:19
Добавление поддержки .NET 4.0 в Visual Studio 2008 является дорогостоящей операцией. Кроме того, Microsoft хочет, чтобы мы купили Visual Studio 2010. Две причины, по которым Microsoft не будет добавлять поддержку .NET 4.0 в Visual Studio 2008.

Ваш ответ на вопрос