Компиляция VLC на Linux: Ошибка не может найти Lua

Я пытаюсь скомпилировать VLC для Linux. Когда я запускаю скрипт настройки, я получаю сообщение об ошибке

настроить: ошибка: не удалось найти lua. Lua необходим для некоторых интерфейсов (rc, telnet, http), а также для многих других пользовательских скриптов. Используйте --disable-lua, чтобы игнорировать эту ошибку.

У меня есть Луа в моей системе. Я побежал Луа-В и получил

Lua 5.1.4 Copyright (C) 1994-2008 Lua.org, PUC-Rio

где Луа дает

/ usr / bin / lua / usr / lib / lua / usr / share / lua /usr/share/man/man1/lua.1.gz

Который выглядит как стандартное место. Любые идеи о том, почему configure не поднимает lua?

 jogabonito29 мар. 2012 г., 14:44
Спасибо, это работает сейчас .. Пожалуйста, напишите ответ, чтобы я мог принять его
 ecle29 мар. 2012 г., 14:38
 jogabonito29 мар. 2012 г., 14:36
Где должны быть заголовки? Я проверил в / usr / include / без удачи.
 Not_a_Golfer29 мар. 2012 г., 14:33
у вас есть заголовки lua?

Ответы на вопрос(2)

Решение Вопроса

На основе Debian

$ apt-get install lua5.2 liblua5.2-dev

Работал для меня

 Shautieh04 сент. 2018 г., 16:45
Я сначала установил то же самое, но с 5.3 без удачи. С 5.2 это действительно прошло!

Ваш ответ на вопрос