у меня работает firebase версия 4.8.2:

отаю над приложением с использованием угловых и FireBase. Я установил FireBase с инструкциями, приведенными на сайте и версиями, как показано ниже,

"angularfire2": "^5.0.0-rc.4",
"firebase": "^4.8.1",

но приходит следующая ошибка

ОШИБКА в node_modules/@firebase/database/dist/esm/src/api/Database.d.ts (4,33): ошибка TS2307: Не удается найти модуль '@ firebase / app-types / private'. node_modules/@firebase/database/dist/esm/src/core/AuthTokenProvider.d.ts (17,39): ошибка TS2307: не удается найти модуль '@ firebase / app-types / private'.

Ответы на вопрос(4)

Решение Вопроса

известная проблема что это проблема с новейшим пакетом npm firebase (v4.8.1).

Вам необходимо откатить версию Firebase до версии 4.8.0. была проблема с определениями типов, и она больше не работает после обновления с 4.8.0 до 4.8.1.

Чтобы исправить это,

Шаг 1: Удалите с помощью следующей команды

npm uninstall --save firebase

Шаг 2: Теперь откройте файл package.json. Там вы найдете:

"angularfire2": "^5.0.0-rc.4"

Шаг 3: Под этой строкой добавьте эту строку (без символа каретки (^)) и сохраните

"firebase": "4.8.0"

Шаг 4: Теперь установите npm. Ваше приложение должно работать

Последнее обновление

Привет ребят! Эта конкретная проблема была решена с помощью запроса на извлечение#391, Ионная команда также откатит часть изменений, которые возникли, поэтому вы не должны больше видеть проблему в следующем выпуске.

 Sandeep Chikhale26 дек. 2017 г., 16:05
Версия - "angularfire2": "^ 5.0.0-rc.4", "firebase": "4.8.0", также пробует эту комбинацию "angularfire2": "5.0.0-rc.4", ИЛИ "angularfire2": "5.0.0-rc.5", "firebase": "4.8.0", пробовал с пряжей и Npm. Кто-нибудь еще сталкивался с проблемой. Столкнувшись с проблемой в этом git-репоgithub.com/Sandeep3005/ng-chat-app, Кто-нибудь может взглянуть
 Nayfin20 мая 2018 г., 23:36
С AF2 и пожарной базой, делающими постоянные изменения, это будет плавный ответ. @SandeepChikhale Не могли бы вы обновить ответ ниже, так как вы лучший ответ?

Решение:

1. Внутри package.json удалите^ из"firebase": "^4.8.1"

1,1 Понизить Firebase с 4.8.1 до 4.8.0, изменив4.8.1 в4.8.0

1.2 Конечный результат должен выглядеть так:"firebase": "4.8.0"

2. Бегатьnpm update в корне проекта. NPM понизит Firebase для вас

3. Бегатьng serve --open проверить на ошибки компиляции. Там не должно быть никаких.

4. Наслаждайтесь!

Причина:

Firebase ввел некоторые серьезные изменения, с которыми AngularFire2 еще не справился. Пока команда AngularFire2 не разработает это, это будет решением.

package.json:

"angularfire2": "^5.0.0-rc.6",
"firebase": "^4.12.1",

установка npm

у меня работает firebase версия 4.8.2:

"angularfire2": "^5.0.0-rc.4",
"firebase": "4.8.2",

Ваш ответ на вопрос