Надеюсь это поможет.

0 silly lifecycle [email protected]~build.prod: Args: [ '/d /s /c',
10 silly lifecycle   'gulp build.prod --color --env-config prod --build-type prod --base /cli/ --theme dark' ]
11 silly lifecycle [email protected]~build.prod: Returned: code: 1  signal: null
12 info lifecycle [email protected]~build.prod: Failed to exec build.prod script
13 verbose stack Error: [email protected] build.prod: `gulp build.prod --color --env-config prod --build-type prod --base /cli/ --theme dark`
13 verbose stack Exit status 1
13 verbose stack     at EventEmitter.<anonymous> (C:\Users\user\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\index.js:285:16)
13 verbose stack     at emitTwo (events.js:126:13)
13 verbose stack     at EventEmitter.emit (events.js:214:7)
13 verbose stack     at ChildProcess.<anonymous> (C:\Users\user\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
13 verbose stack     at emitTwo (events.js:126:13)
13 verbose stack     at ChildProcess.emit (events.js:214:7)
13 verbose stack     at maybeClose (internal/child_process.js:925:16)
13 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)
14 verbose pkgid [email protected]
15 verbose cwd C:\dev\JWT\Mvc\StorkCMS\Stork.SPA
16 verbose Windows_NT 10.0.17025
17 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Users\\user\\AppData\\Roaming\\npm\\node_modules\\npm\\bin\\npm-cli.js" "run" "build.prod"
18 verbose node v8.9.3
19 verbose npm  v5.6.0
20 error code ELIFECYCLE
21 error errno 1
22 error [email protected] build.prod: `gulp build.prod --color --env-config prod --build-type prod --base /cli/ --theme dark`
22 error Exit status 1
23 error Failed at the [email protected] build.prod script.
23 error This is probably not a problem with npm. There is likely additional logging output above.
24 verbose exit [ 1, true ]

ppData \ Roaming \ npm \ node_modules \ npm \ node_modules \ npm-lifecycle \ lib нет index.js, только spawn.js

Ответы на вопрос(1)

Решение Вопроса

убедитесь, что вы изменили значение

import {Observable} из 'rxjs / Rx';

в

import {Observable} из 'rxjs / observable';

через ваше рабочее пространство

А затем убедитесь, что вы вернули / обновили свою машинопись до версии 2.3.4 и rxjs до версии 5.6.0. Сделайте очистку кеша npm и соберите заново

Это сработало для меня. Кажется, есть некоторая проблема в совместимости библиотек rxjs и версий машинописного текста.

Надеюсь это поможет.

Ваш ответ на вопрос