Установка npm --save-dev @ ngtools / webpack @ latest

у обновить angular 4 с asp.net core2 до angular 5 (последняя версия)

Я сделал это шаги:

дотнет новый угловой

npm install @ angular / animations @ latest @ angular / common @ latest @ angular / compiler @ latest @ angular / compiler-cli @ latest @ angular / core @ latest @ angular / forms @ latest @ angular / http @ latest @ angular / платформа -browser @ latest @ angular / platform-browser-dynamic @ latest @ angular / platform-server @ latest @ angular / router @ последний rxjs @ последний --save
npm install [email protected] - сохранить-точно

npm install (чтобы убедиться)

DotNet Run

и это приводит к ошибке: (Версия @ angular / compiler-cli должна быть 2.3.1 или выше. Текущая версия "5.1.0".) и я понятия не имею, как это исправить.

мой пакет.json

{
  "name": "MyApp",
  "private": true,
  "version": "0.0.0",
  "scripts": {
    "test": "karma start ClientApp/test/karma.conf.js"
  },
  "devDependencies": {
    "@angular/animations": "^5.1.0",
    "@angular/cli": "^1.6.0",
    "@angular/common": "^5.1.0",
    "@angular/compiler": "^5.1.0",
    "@angular/compiler-cli": "^5.1.0",
    "@angular/core": "^5.1.0",
    "@angular/forms": "^5.1.0",
    "@angular/http": "^5.1.0",
    "@angular/platform-browser": "^5.1.0",
    "@angular/platform-browser-dynamic": "^5.1.0",
    "@angular/platform-server": "^5.1.0",
    "@angular/router": "^5.1.0",
    "@ngtools/webpack": "1.5.0",
    "@types/chai": "4.0.1",
    "@types/jasmine": "2.5.53",
    "@types/webpack-env": "1.13.0",
    "angular2-router-loader": "0.3.5",
    "angular2-template-loader": "0.6.2",
    "aspnet-prerendering": "^3.0.1",
    "aspnet-webpack": "^2.0.1",
    "awesome-typescript-loader": "3.2.1",
    "bootstrap": "3.3.7",
    "chai": "4.0.2",
    "css": "2.2.1",
    "css-loader": "0.28.4",
    "es6-shim": "0.35.3",
    "event-source-polyfill": "0.0.9",
    "expose-loader": "0.7.3",
    "extract-text-webpack-plugin": "2.1.2",
    "file-loader": "0.11.2",
    "html-loader": "0.4.5",
    "isomorphic-fetch": "2.2.1",
    "jasmine-core": "2.6.4",
    "jquery": "3.2.1",
    "json-loader": "0.5.4",
    "karma": "1.7.0",
    "karma-chai": "0.1.0",
    "karma-chrome-launcher": "2.2.0",
    "karma-cli": "1.0.1",
    "karma-jasmine": "1.1.0",
    "karma-webpack": "2.0.3",
    "preboot": "4.5.2",
    "raw-loader": "0.5.1",
    "reflect-metadata": "0.1.10",
    "rxjs": "^5.5.5",
    "style-loader": "0.18.2",
    "to-string-loader": "1.1.5",
    "typescript": "2.4.2",
    "url-loader": "0.5.9",
    "webpack": "2.5.1",
    "webpack-hot-middleware": "2.18.2",
    "webpack-merge": "4.1.0",
    "zone.js": "0.8.12"
  }
}

Вот ошибки исключения, которые произвели:

Использование параметров запуска из f: \ temp \ WebAppLinkSys \ MyApp \ MyApp \ Properties \ launchSettings.json ... info: Microsoft.AspNetCore.DataProtection.KeyManagement.XmlKeyManager [0] Доступен профиль пользователя. Использование «C: \ Users \ adwin \ AppData \ Local \ ASP.NET \ DataProtection-Keys» в качестве хранилища ключей и Windows DPAPI для шифрования ключей в покое. Исключение при запуске приложения: System.AggregateException: произошла одна или несколько ошибок. (Версия @ angular / compiler-cli должна быть 2.3.1 или выше. Текущая версия "5.1.0". Ошибка: Версия @ angular / compiler-cli должна быть 2.3.1 или выше. Текущая версия " 5.1.0 ". At Object. (F: \ temp \ WebAppLinkSys \ MyApp \ MyApp \ node_modules \ @ngtools \ webpack \ src \ index.js: 27: 11) в Module._compile (module.js: 641: 30) в Object.Module._extensions..js (module.js: 652: 10) в Module.load (module.js: 560: 32) в tryModuleLoad (module.js: 503: 12) в Function.Module._load (модуль .js: 495: 3) в Module.require (module.js: 585: 17) по требованию (internal / module.js: 11: 18) в Object. (f: \ temp \ WebAppLinkSys \ MyApp \ MyApp \ webpack. config.js: 4: 19) в Module._compile (module.js: 641: 30)) ---> Microsoft.AspNetCore.NodeServices.HostingModels.NodeInvocationException: версия @ angular / compiler-cli должна быть 2.3.1 или больше Текущая версия "5.1.0".

 nightingale2k112 дек. 2017 г., 00:48
нашел ответstackoverflow.com/questions/47105660/... путем обновления веб-пакета npm установите --save-dev @ ngtools / webpack @ latest
 nightingale2k112 дек. 2017 г., 00:49
 Camilo Terevinto12 дек. 2017 г., 00:21
Это совершенно не связано с ASP.NET Core и c #. Пожалуйста, помечайте только соответствующие теги.
 nightingale2k112 дек. 2017 г., 00:13
Я пыталсяstackoverflow.com/questions/47104188/... это решение, но не работает. до сих пор производит тот же Erorr

Ответы на вопрос(1)

Решение Вопроса

После обновления до angular 5 команда webpack не работает

Установка npm --save-dev @ ngtools / webpack @ latest

Ваш ответ на вопрос