v8.1.4

й раз, когда я пытаюсь установить любой пакет или даже если я пытаюсь сделатьnpm install Я продолжаю получать эту ошибку. Я понятия не имею, почему я получаю ошибку. Я абсолютно новичок в Angular 4, это всего лишь неделя, поэтому любые предложения будут оценены. Я использую узел -v 8.8.1 и @ angular / cli 1.4.9.

Это мой package.json.

{
    "name": "events-across", 
    "version": "0.0.0", 
    "license": "MIT", 
    "scripts": {
        "ng": "ng", 
        "start": "ng serve", 
        "build": "ng build", 
        "test": "ng test", 
        "lint": "ng lint", 
        "e2e": "ng e2e"
    }, 
    "private": true, 
    "dependencies": {
        "@angular/animations": "^4.2.4", 
        "@angular/common": "^4.2.4", 
        "@angular/compiler": "^4.2.4", 
        "@angular/core": "^4.2.4", 
        "@angular/forms": "^4.2.4", 
        "@angular/http": "^4.2.4", 
        "@angular/platform-browser": "^4.2.4", 
        "@angular/platform-browser-dynamic": "^4.2.4", 
        "@angular/router": "^4.2.4", 
        "angular-font-awesome": "^2.3.7", 
        "angular4-carousel": "^3.1.8", 
        "bootstrap": "^4.0.0-beta", 
        "core-js": "^2.4.1", 
        "font-awesome": "^4.7.0", 
        "ng2-opd-popup": "^1.1.21", 
        "rxjs": "^5.4.2", 
        "zone.js": "^0.8.14"
    }, 
    "devDependencies": {
        "@angular/cli": "1.4.9", 
        "@angular/compiler-cli": "^4.2.4", 
        "@angular/language-service": "^4.2.4", 
        "@types/jasmine": "~2.5.53", 
        "@types/jasminewd2": "~2.0.2", 
        "@types/node": "~6.0.60", 
        "codelyzer": "~3.2.0", 
        "jasmine-core": "~2.6.2", 
        "jasmine-spec-reporter": "~4.1.0", 
        "karma": "~1.7.0", 
        "karma-chrome-launcher": "~2.1.1", 
        "karma-cli": "~1.0.1", 
        "karma-coverage-istanbul-reporter": "^1.2.1", 
        "karma-jasmine": "~1.1.0", 
        "karma-jasmine-html-reporter": "^0.2.2", 
        "protractor": "~5.1.2", 
        "ts-node": "~3.2.0", 
        "tslint": "~5.7.0", 
        "typescript": "~2.3.3"
    }
}

Ответы на вопрос(1)

Решение Вопроса

Возможная проблемаВот

 Soumyadip Chakraborty07 нояб. 2017 г., 08:41
Да, конечно :)....
 Oleksandr Buchek02 нояб. 2017 г., 14:22
Можете ли вы отметить, что мой ответ правильный, пожалуйста :)
 Soumyadip Chakraborty02 нояб. 2017 г., 13:52
Да, спасибо, я использовал rm package-lock.json, и он добился цели.
 ndbroadbent12 дек. 2018 г., 12:47
Для всех, кто сталкивался с этим: у меня была та же проблема, и это было вызвано плохим разрешением конфликта слияния вpackage-lock.json, (Git добавил<<<<<<< HEAD ... ======= ... >>>>>>> master строк в файл.) Но было очень неприятно, что сообщение об ошибке ничего не говорит оpackage-lock.json.

Ваш ответ на вопрос