вокруг OS 4 методы, которые вы хотите использовать. Если вы вызвали метод, который существовал только в iOS 4 на устройстве iOS 3, ваше приложение зависло бы. Это можно сделать как путем проверки номеров версий iOS, так и с помощью метода [... responsedsToSelector:].

ою свой проект с последним SDK (4.1) и устанавливаю «iOS Deployment Target» (3.0). Могу ли я запустить свой проект на реальном iPhone 3.0, если я использую некоторые методы 4.0 SDK?

Ответы на вопрос(1)

Решение Вопроса

условно код вокруг OS 4 методы, которые вы хотите использовать. Если вы вызвали метод, который существовал только в iOS 4 на устройстве iOS 3, ваше приложение зависло бы. Это можно сделать как путем проверки номеров версий iOS, так и с помощью метода [... responsedsToSelector:].

Ваш ответ на вопрос