Попробуйте обновить Firebase до последней версии.

блачные функции используют для работы. Теперь я попробовал развернуть облачные функции и получил:

Ошибка:

⚠  functions[limitTasksPerCreatorFirestore]: Deploy Error: Failed to configure trigger providers/cloud.firestore/eventTypes/[email protected] (limitTasksPerCreatorFirestore)
⚠  functions[sendEmail]: Deploy Error: Failed to configure trigger providers/cloud.firestore/eventTypes/[email protected] (sendEmail)

мойpackage.json:

"@google-cloud/firestore": "0.8.1",
"firebase-admin": "5.4.2",
"firebase-functions": "0.7.1",
"nodemailer": "4.2.0"
 Sam Stern20 окт. 2017 г., 18:05
Можете ли вы показать свою функцию, которую не удается развернуть?
 laurenzlong20 окт. 2017 г., 20:13
Можете ли вы поделиться, как вы объявили функцию?
 woisme20 окт. 2017 г., 13:28
Точно так же здесь
 Vishu20 окт. 2017 г., 18:06
та же проблема здесь.
 ProblemsOfSumit20 окт. 2017 г., 16:56
та же ошибка для меня. Работали нормально до сих пор. Это блокирует меня полностью :-(

Ответы на вопрос(1)

Решение Вопроса

и теперь она была решена командой пожарной команды.

от провала базы

eob [12:32 AM] Firebase dev снова здесь с обновлением о проблемах развертывания функций с помощью триггеров Firestore. Мы полагаем, что теперь мы определили и исправили проблему, а исправление теперь полностью развернуто. Снова извиняюсь за срыв.

Я проверил сейчас, и мои функции снова развертываются!

 Jeff Padgett28 нояб. 2017 г., 16:58
Привет, Eamonn, у меня все та же проблема, но только с .onUpdate. onWrite, onCreate работают нормально. Я сократил код в функции до простого журнала консоли, все еще выдает ошибку при развертывании. "Ошибка развертывания. Не удалось настроить триггерные провайдеры/cloud.firestore/eventTypes/[email protected] <functionName>
 Eamonn O'Brien-Strain22 окт. 2017 г., 01:04
Разработчик Firebase подтвердил мое обновление Slack: мы действительно определили и решили проблему, касающуюся развертывания функций для некоторых проектов с триггерами Firestore. Спасибо тем, кто сообщил о проблеме, и извините за нарушение.
 Jeff Padgett30 окт. 2018 г., 18:41
Попробуйте обновить Firebase до последней версии.
 has1929 окт. 2018 г., 19:45
@JeffPadget ты решил? я получаю ту же ошибку
 Gal Bracha22 окт. 2017 г., 01:19
Да, это работает сейчас. Спасибо @ EamonnO'Brien-Strain

Ваш ответ на вопрос