(Я не знаю почему ...)

учаю следующую ошибку при попытке включить приложение в Cloud FireStore

[!] Невозможно удовлетворить следующие требования:

Firebase/Firestore требуетсяPodfile

Спецификации, удовлетворяющиеFirebase/Firestore зависимости были найдены, но они требовали более высокой минимальной цели развертывания.

Я изменил требование подфайла на 10.2, а развертывание xcode на 10.2, и я все еще получаю эту ошибку. Какие-либо предложения?

Изменить: решение для меня

Я сделал pod repo update pod, pod install, затем pod обновил его в том порядке, и он заработал.

 Jen Person05 окт. 2017 г., 21:20
ты бежалpod update после смены подфайла?
 Blue06 окт. 2017 г., 22:41
Это было близко к этому. Я добавлял в существующий проект, поэтому я сделал pod repo update pod, pod install, затем pod обновил его в том порядке, и он заработал.

Ответы на вопрос(8)

едняя версия iOS - 12. Кроме того, установка этой версии в приложении, ошибка все еще появлялась.

Решением для меня былоудалить файл podfile.lock (Я не знаю почему ...)

Вот.

Самый простой Podfile, который использует это, выглядит так:

platform :ios, '8.0'
use_frameworks!

target 'MyApp' do
  pod 'Firebase/Core'
  pod 'Firebase/Firestore'
end

Цель развертывания XCode для вашего приложения не должна иметь никакого влияния наpod install.

начало видео показывает все это в действии.

 Gil Gilbert06 окт. 2017 г., 01:10
Это становится слишком болтливым для stackoverflow. Можете ли вы задать этот вопрос на firebase-talk, и мы отладим его там?groups.google.com/forum/#!forum/firebase-talk
 Blue06 окт. 2017 г., 00:30
Я очень ценю, что вы нашли время, чтобы помочь, я просто спрашивал, есть ли у вас более индивидуальный совет. Но в любом случае спасибо, что нашли время!
 Gil Gilbert06 окт. 2017 г., 00:25
Если не считать вашего настоящего подфайла, я не уверен, что еще я могу сказать.
 Blue06 окт. 2017 г., 00:10
Да, я полностью осведомлен, и я получил FireBase в режиме реального времени, работая вместе с другими инструментами FireBase. У меня также были ошибки podfile раньше, но не это. Мне интересно, есть ли у вас какое-либо понимание этой конкретной ошибки, потому что общая помощь в подфайлах - это не то, что мне нужно. Спасибо.

удовлетворяющие зависимости Firebase / Functions, но они требовали более высокой минимальной цели развертывания.), Когда я пытался добавить firebase / Functions в мой файл pod.

После нескольких попыток я решил удалить все модули и запустить установку pod для каждой нужной строки, одну за другой, не устанавливая все одновременно. В конце я обнаружил, что проблема была в модуле «Firebase / Core», и я установил его напоследок, и теперь все установлено нормально.

Теперь это мой стручок.

def shared_pods
    use_frameworks!
    pod 'Firebase/Functions'
    pod 'Firebase/Core'
    pod 'Firebase/Firestore'
    pod 'Firebase/Storage'
    pod 'Firebase/Database'
    pod 'FirebaseUI/Storage'
    pod 'SDWebImage'
    pod 'Fabric'
    pod 'Crashlytics'
end


Установка FirebaseInAppMessagingDisplay (0.12.0)

pod repo update, pod install, pod update и даже обновленные кокоаподы.

Оказалось, у меня все еще былоFirebaseDatabase стручок вpodfile.

Удаление, которое решило проблему.

Это оно,

pod repo update
pod update

Удалитьpod 'Firebase/Firestore' из вашего подфайла, тогда:

pod repo update

pod update

Потом добавляюpod 'Firebase/Firestore' в мой Podfile и, наконец, выполнитьpod install

Решение Вопроса

Я добавил в существующий проект, поэтому я сделал

pod repo update
pod install
pod update 

это тот порядок, и это сработало.

Я не уверен, почему этот заказ сработал, я полагаю, что он может что-то очистить / сбросить где-то в дополнениях Firebase.

 The Windwaker04 февр. 2018 г., 16:13
так же, как @BenSullivan. Большое спасибо !
 Ben Sullivan11 окт. 2017 г., 12:58
Установка не работала для меня даже после обновления репозитория, но выполнение обновления и установка работали :)
 Blue12 окт. 2017 г., 21:36
Рад слышать, что это сработало, надеюсь, если мой заказ не сработает для некоторых людей, ваш будет.
 Lance Samaria19 нояб. 2018 г., 10:16
этот порядок не помог исправитьFirebase/Core но это сработало для всего остального

Ваш ответ на вопрос