Я бы порекомендовал перейти с # 1, то есть использовать последнюю версию Storage Emulator.

обновления моей версии Azure Storage Explorer мой код перестает работать со следующим сообщением:

«REST-версия этого запроса не поддерживается в этом выпуске эмулятора хранилища. Обновите эмулятор хранилища до последней версии. Дополнительные сведения см. По следующему URL-адресу:http://go.microsoft.com/fwlink/?LinkId=392237"

Моя версия Azure Storage Explorer - 0.8.16.

В основном код для загрузки в Azure, как правило, выглядит следующим образом:

CloudStorageAccount storageAccount = CloudStorageAccount.Parse("UseDevelopmentStorage=true");        
CloudBlobClient blobClient = storageAccount.CreateCloudBlobClient();
CloudBlobContainer blobContainer = blobClient.GetContainerReference("mycontainer");
blobContainer.CreateIfNotExistsAsync();
CloudBlockBlob blockBlob = this.blobContainer.GetBlockBlobReference(fileName);
byte[] CoverImageBytes = null; 
BinaryReader reader = new BinaryReader(file.OpenReadStream()); 
CoverImageBytes = reader.ReadBytes((int)file.Length);
await blockBlob.UploadFromByteArrayAsync(CoverImageBytes, 0,(int)file.Length);

Исключение выдает в последней строке.

ОБНОВИТЬ

1) Какую версию эмулятора хранилища вы используете?

V5.1

2) Какую версию библиотеки Storage Client вы используете в своем коде?

8.4.0 Вот

 Gaurav Mantri20 сент. 2017 г., 05:29
Я не думаю, что эта ошибка имеет какое-либо отношение к Azure Storage Explorer. Подскажите, пожалуйста: 1) Какую версию эмулятора хранилища вы используете? 2) Какую версию библиотеки Storage Client вы используете в своем коде?
 Jhonatas Kleinkauff20 сент. 2017 г., 13:30
Забыл упомянуть всю эту информацию. Обновил вопрос, спасибо @GauravMantri

Ответы на вопрос(1)

Решение Вопроса

по которой вы получаете эту ошибку, заключается в том, что Storage Client Library 8.4 предназначена для версии REST API.2017-04-17 где Storage Emulator версии 5.1 предназначен для версии REST API2016-05-31.

Вы можете сделать одну из двух вещей:

Установите последнюю версию Storage Emulator (сейчас 5.2).Понизьте клиентскую библиотеку хранилища до версии 8.3, которая поддерживает версию REST API.2016-05-31.

Я бы порекомендовал перейти с # 1, то есть использовать последнюю версию Storage Emulator.

Ваш ответ на вопрос