Версия Джексона слишком старая

У меня есть следующееbuild.sbt файл:

name := "myProject"

version := "1.0"

scalaVersion := "2.11.8"

javaOptions ++= Seq("-Xms512M", "-Xmx2048M", "-XX:MaxPermSize=2048M", "-XX:+CMSClassUnloadingEnabled")


dependencyOverrides ++= Set(
  "com.fasterxml.jackson.core" % "jackson-core" % "2.8.1"
)

// additional libraries
libraryDependencies ++= Seq(
  "org.apache.spark" %% "spark-core" % "2.0.0" % "provided",
  "org.apache.spark" %% "spark-sql" % "2.0.0" % "provided",
  "org.apache.spark" %% "spark-hive" % "2.0.0" % "provided",
  "com.databricks" %% "spark-csv" % "1.4.0",
  "org.scalactic" %% "scalactic" % "2.2.1",
  "org.scalatest" %% "scalatest" % "2.2.1" % "test",
  "org.scalacheck" %% "scalacheck" % "1.12.4",
  "com.holdenkarau" %% "spark-testing-base" % "2.0.0_0.4.4" % "test",
)

Однако, когда я запускаю код, я получаю эту ошибку:

An exception or error caused a run to abort. 
java.lang.ExceptionInInitializerError
Caused by: com.fasterxml.jackson.databind.JsonMappingException: Jackson version is too old 2.4.4
    at com.fasterxml.jackson.module.scala.JacksonModule$class.setupModule(JacksonModule.scala:56)
    at com.fasterxml.jackson.module.scala.DefaultScalaModule.setupModule(DefaultScalaModule.scala:19)
    at com.fasterxml.jackson.databind.ObjectMapper.registerModule(ObjectMapper.java:549)
    at org.apache.spark.rdd.RDDOperationScope$.<init>(RDDOperationScope.scala:82)
    at org.apache.spark.rdd.RDDOperationScope$.<clinit>(RDDOperationScope.scala)
    ... 58 more

Почему это так? Я добавил новую версию Джексона вdependencyOverrides(после просмотра здесьРаспараллелить искру? (Не удалось найти свойство создателя с именем 'id')), поэтому старая версия не должна использоваться.

 duffymo31 июл. 2016 г., 19:13
Это должно быть что-то еще, что тянет в старой версии как зависимость. Вам нужно будет найти, что это такое, и получить версию, которая соответствует Джексону. Maven сделает это легко понять.
 insan-e31 июл. 2016 г., 22:17
Попробуйте добавить зависимость Джексона вlibraryDependencies с `force ()` в конце:libraryDependencies ++= Seq( ... "com.fasterxml.jackson.core" % "jackson-core" % "2.8.1" force()

Ответы на вопрос(1)

Версии jackson-core и jackson-databind должны совпадать (по крайней мере, до минорной версии, я считаю).

Так что удалитеdependencyOverrides и имеют

libraryDependencies ++= Seq(
  ...
  "com.fasterxml.jackson.core" % "jackson-databind" % "2.8.1"
)

Или укажите оба вdependencyOverrides

dependencyOverrides ++= Set(
  "com.fasterxml.jackson.core" % "jackson-core" % "2.8.1"
  "com.fasterxml.jackson.core" % "jackson-databind" % "2.8.1"
)

Хотя я не уверен, что понимаю, что вы пытаетесь сделать; связанный вопрос, кажется, говорит о том, что вы должны использовать более старую версию (2.4.4).

Ваш ответ на вопрос