Какой плагин / модуль Spring Sec OAuth следует использовать в Grails 3.x?

Я пытаюсь перенести проект Grails 2.5 в Grails 3.1.4. В моем старом BuildConfig я использовал следующее:

plugins {
  compile ':spring-security-core:2.0-RC5'
  compile ':spring-security-oauth:2.1.0-RC4'
  compile ':spring-security-oauth-facebook:0.2'
  compile ':spring-security-oauth-google:0.3.1'
}

Теперь мой build.gradle выглядит так:

dependencies {
  compile 'org.grails.plugins:spring-security-core:3.1.1'
  //compile 'org.grails.plugins:spring-security-oauth:2.1.0-RC4'
  //compile 'org.grails.plugins:spring-security-oauth-facebook:0.2'
  //compile 'org.grails.plugins:spring-security-oauth-google:0.3.1'
}

Сборка прошла успешно, пока я не раскомментирую закомментированные строки. Это приводит к таким ошибкам, как:

Could not resolve all dependencies for configuration ':runtime'.
 Could not find spring-security-core.zip (org.grails.plugins:spring-security-core:3.1.1).
   Searched in the following locations:
     https://repo.grails.org/grails/core/org/grails/plugins/spring-security-core/3.1.1/spring-security-core-3.1.1.zip

Итак, как правильно установить и использовать плагин OAuth (2?) В Grails 3?

 Balkrishna06 нояб. 2016 г., 17:43
Есть ли успехи в этом?
 injecteer06 нояб. 2016 г., 21:16
смотри мой ответ ниже

Ответы на вопрос(2)

Решение Вопроса

Извините, я забыл ответить, но @injecteer В настоящее время я тестирую следующие плагины с Grails 3.2.2 и пока что он работает. Поэтому я думаю, что принятый ответ больше не действителен.

compile "org.grails.plugins:spring-security-oauth2:1.1.0"
compile "org.grails.plugins:spring-security-oauth2-facebook:1.0.0"
compile "org.grails.plugins:spring-security-oauth2-google:1.1.0"
 injecteer19 дек. 2016 г., 16:51
наконец я получил это работает, фу

На данный момент для Grails 3.x не доступны OAuth-плагины Spring Security. Единственный вариант - использовать клиентские решения на основе JS. Так же, какAndroid / iOS аутентификации работают без каких-либо плагинов на стороне сервера.

 Balkrishna06 нояб. 2016 г., 23:20
Извините, но плагин работает только имя пакета отличается. Пожалуйста, найдите мой ответ ниже.
 Dipak Thoke07 нояб. 2016 г., 06:11
Вы хотите плагин аутентификации и авторизации @injecteer ?? в Граале

Ваш ответ на вопрос