CommandInvokationFailure ошибка при сборке APK?

Я получаю следующую ошибку при создании моего APK:

CommandInvokationFailure: Failed to re-package resources. See the Console for details.
    C:\Users\Me\AppData\Local\Android\sdk\build-tools\24.0.0\aapt.exe package --auto-add-overlay -v -f -m -J gen -M AndroidManifest.xml -S "res" -I "C:/Users/Me/AppData/Local/Android/sdk\platforms\android-24\android.jar" -F bin/resources.ap_ --extra-packages

Я хочу интегрировать «Таблицы лидеров» в свое приложение, используя Сервисы Google Play. Что я должен сделать, чтобы это исправить?

Что я пробовал:

Переустановка плагина Google Play Services.Обновление SDK:Посмотреть здесь, (скажите, правильно ли я это сделал)Убедитесь, что у меня установлены последние версии «Extras / Репозиторий поддержки Android» и «Extras / Google Repository».Все установлено в SDK Manager. УвидетьВот.Обновление Unity.Перезапуск.Немного мелких изменений.
 Programmer01 июл. 2016 г., 19:13
Попробуйте мой ответ. Комментарий под ним, если есть проблема.
 Dinovr30 июн. 2016 г., 19:10
@Programmer Спасибо за напоминание. Я сейчас принял 2 ответа. Мои другие вопросы остаются нерешенными.
 user653702201 июл. 2016 г., 10:32
@ Programmer Кроме того, я не мог найти другой способ общения с вами.
 Dinovr28 июн. 2016 г., 15:01
@UmairM Я не использую AdMob.
 Umair M28 июн. 2016 г., 14:08
Несколько полезных ссылок:1 2 3
 Programmer30 июн. 2016 г., 16:00
Хорошо. Вы никогда не получали ответа, даже если большинство ваших вопросов очень полезно и, вероятно, решило вашу проблему. Вот как принять ответ:i.stack.imgur.com/LkiIZ.png Проверьте свой вопрос и посмотрите, какие из них решили вашу проблему, затем отметьте их. Дайте мне знать после того, как вы это сделаете.
 Dinovr28 июн. 2016 г., 14:50
@ UmairM Я видел эти сайты раньше, и они не предложили мне решение.
 Umair M28 июн. 2016 г., 14:56
Используете ли вы как Google-Play-Services и AdMob?
 user653702201 июл. 2016 г., 10:28
@ Программист я обычно простостроить мой APK без сборки и запуска, так что версия Android для моего устройства здесь не имеет значения. Наконец, я удалил плагин Google Play Services из своего проекта Unity, и у меня все еще остается та же проблема! Даже если я создам новый, совершенно новый проект Unity, ошибка все еще появляется! Мне определенно нужна помощь сейчас, потому что я вообще не могу строить ...
 Dinovr30 июн. 2016 г., 15:17
@ Программист Нет, моя проблема до сих пор не решена.
 user653702201 июл. 2016 г., 10:26
@ Программист Привет. Я пишу это со своего второго аккаунта, потому что мой основной аккаунт был заблокирован (7 дней) за нарушение правил голосования. Здесь мы идем: я в настоящее время используюUnity 5.3.5f1, Я попытался понизить до 5.3.4f1, 5.3.3f1 и 5.3.2f1, но это не решило проблему. Я пытался изменить минимальный уровень API на последние версии, и это тоже не решило проблему. В настоящее время мой уровень API установлен на уровень API 9. Я создал новый проект и попытался создать APK, и появляется та же ошибка.
 Programmer30 июн. 2016 г., 15:15
Не могу поверить, что вы все установили. Вы скоро исчерпаете пространство. У меня есть возможное решение. Это решено еще?
 Programmer30 июн. 2016 г., 19:33
Nice.Update ваш вопрос с версией Unity вы используете иМинимальный уровень API это установлено в. Также укажите, какая версия Android работает на вашем Android-устройстве. Прежде чем я поставлю свой ответ. Пожалуйста, создайте новый проект, затем попробуйтестроить это в Android. Не ** построить и запустить **. Простостроить это и скажите мне, если вам удалось его построить.

Ответы на вопрос(2)

Чтобы исправить эту ошибку, вы должны скопировать файл version.xml из

Android-SDK / дополнительные / Google / google_play_services / libproject / Google-игра-services_lib / RES / значения /

в

Активы / Plugins / Android / RES / значения /

папки вашего проекта Unity.

 Dinovr28 июн. 2016 г., 15:04
Благодарю. Но у меня нетlibproject папка подgoogle_play_services.
 Umair M29 июн. 2016 г., 15:39
пытатьсяэтот
 Umair M28 июн. 2016 г., 15:03
создайте папку res под плагинами / Android /
 user606828729 июн. 2016 г., 12:53
@ UmairM Меня также интересует ответ на этот вопрос.
 Dinovr28 июн. 2016 г., 15:00
Я не могу найтиandroid-sdk , Где это находится?
 Umair M29 июн. 2016 г., 17:19
 Umair M29 июн. 2016 г., 15:36
все еще не могу найти папку "res"?
 Dinovr28 июн. 2016 г., 15:01
Кроме того, у меня нетres папка.
 Umair M29 июн. 2016 г., 13:27
@Dinovr убедитесь, что вы установили "Google API", а не только элементы инструментов. Если вы не можете найти "Google API" в SDK Manager. Просто установите все.
 Dinovr28 июн. 2016 г., 17:11
Мой SDK обновлен. Посмотрите:imgur.com/LtSFkpO Но у меня все та же проблема.
 Dinovr29 июн. 2016 г., 16:31
@UmairM У меня уже установлены сервисы Google Play.
 Umair M28 июн. 2016 г., 15:02
В едином меню Edit-> Preferences -> External Tools -> SDk-path
 Umair M28 июн. 2016 г., 15:27
если его нет в папке, вы можете открыть его из Android Studio / Eclipse. Если у вас его нет, то сначала установите Android Studio. (developer.android.com/studio/intro/update.html#sdk-manager)
 Dinovr28 июн. 2016 г., 15:22
Где это точно? Я не могу найти это. Вот скриншот пути SDK:imgur.com/WugeBz4 Это проблема.
 Dinovr29 июн. 2016 г., 16:36
@ UmairM у меня до сих пор нетlibproject папка подgoogle_play_services.
 Dinovr29 июн. 2016 г., 13:43
@UmairM Я буквально все установил. Посмотрите:i.imgur.com/poEFcfJ.gifv
 Umair M28 июн. 2016 г., 15:17
В папке Android SDK: получить его из Правка-> Настройки -> Внешние инструменты -> SDk-путь
 Umair M29 июн. 2016 г., 13:27
@ Gog65 Следуйте инструкциям в моем ответе. Дайте мне знать, если это работает
 Umair M28 июн. 2016 г., 15:09
обновить SDK с помощью SDkManager.exe в папке SDK

Это абсолютно решит вашу проблему.

Загрузите google_play_services по этой ссылке ниже:

https://dl-ssl.google.com/android/repository/google_play_services_8298000_r28.zip

Затем распакуйте его.

после распаковки скопируйте файл в:

Android-SDK / статистов / Google / google_play_services /

Найдите файл version.xml в zip-файле:

Android-SDK / дополнительные / Google / google_play_services / libproject / Google-игра-services_lib / RES / значения /

и скопируйте его в:

Активы / Plugins / Android / RES / значения /

В папке единства

Это работа для меня.

Ваш ответ на вопрос