npm устанавливает ошибку sqlite3

я не уверен, почему, но у меня возникают проблемы при установке любого из пакетов с использованием npm. Я попытался установить sqlite3, и он выдал ошибку следующим образом:

<code>    [email protected]:~$ sudo npm install sqlite3
    [sudo] password for naphstor: 

    > [email protected] preinstall /home/naphstor/node_modules/sqlite3
    > node-waf clean || true; node-waf configure build

    Nothing to clean (project not configured)
    Setting srcdir to                        : /home/naphstor/node_modules/sqlite3 
    Setting blddir to                        : /home/naphstor/node_modules/sqlite3/build 
    Checking for program g++ or c++          : /usr/bin/g++ 
    Checking for program cpp                 : /usr/bin/cpp 
    Checking for program ar                  : /usr/bin/ar 
    Checking for program ranlib              : /usr/bin/ranlib 
    Checking for g++                         : ok  
    Checking for node path                   : not found 
    Checking for node prefix                 : ok /usr/local 
    Checking for sqlite3                     : not found 
    Checking for library sqlite3             : not found 
    /home/naphstor/node_modules/sqlite3/wscript:29: error: the configuration failed (see             '/home/naphstor/node_modules/sqlite3/build/config.log')                                            
    npm ERR! error installing [email protected] Error: [email protected] preinstall: `node-waf        clean || true; node-waf configure build`
    npm ERR! error installing [email protected] `sh "-c" "node-waf clean || true; node-waf configure build"` failed with 1
    npm ERR! error installing [email protected]     at ChildProcess.<anonymous>  (/usr/local/lib/node_modules/npm/lib/utils/exec.js:49:20)
    npm ERR! error installing [email protected]     at ChildProcess.emit (events.js:70:17)
    npm ERR! error installing [email protected]     at maybeExit (child_process.js:359:16)
    npm ERR! error installing [email protected]     at Process.onexit               (child_process.js:395:5)
    npm ERR! [email protected] preinstall: `node-waf clean || true; node-waf configure  build`
    npm ERR! `sh "-c" "node-waf clean || true; node-waf configure build"` failed with 1
    npm ERR! 
    npm ERR! Failed at the [email protected] preinstall script.
    npm ERR! This is most likely a problem with the sqlite3 package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR!     node-waf clean || true; node-waf configure build
    npm ERR! You can get their info via:
    npm ERR!     npm owner ls sqlite3
    npm ERR! There is likely additional logging output above.
    npm ERR! 
    npm ERR! System Linux 3.0.0-12-generic
    npm ERR! command "node" "/usr/local/bin/npm" "install" "sqlite3"
    npm ERR! cwd /home/naphstor
    npm ERR! node -v v0.5.11-pre
    npm ERR! npm -v 1.0.106
    npm ERR! code ELIFECYCLE
    npm ERR! 
    npm ERR! Additional logging details can be found in:
    npm ERR!     /home/naphstor/npm-debug.log
    npm not ok
    [email protected]:~$ 
</code>

Любая идея, почему это так. он показывает такую же ошибку при установке любого из других пакетов.

Я могу сделать это с помощью обходного пути, подобного git clone git: //github.com/developmentseed/node-sqlite3.git" но мне было интересно, почему npm выдает ошибку при установке любого из этих пакетов.

Ответы на вопрос(3)

и это сработало.

Или попробуйте один из следующих пакетов:

https: //github.com/grumdrig/node-sqlit
https: //github.com/orlandov/node-sqlit

npm install sqlite3 --build-from-source

Убедитесь, что у вас установлены следующие зависимости

Питон-софт-свойство Питонg ++сделат Наращивание важно

или бегиsudo npm install -g node-gyp

Вы найдете больше информации там (раздел SQlite3):http: //support.ghost.org/troubleshooting

затем я удалил узел js, который я скачал и установил из репозитория Ubuntu, и загрузил исходный код из Официальный узел js site и скомпилировал после того, как он снова попытался установить sqlite без проблем, он работал, я советую вам также обновить версию вашего узла и npm

Ваш ответ на вопрос