Установите расширение fileinfo php

По мере того как fileinfo перемещается из PECL в PHP. Как лучше всего установить его через WHM или putty.?

Я попробовал следующую команду:

<code>pecl install fileinfo
</code>

и получил следующую ошибку:

WARNING: "pear/Fileinfo" is deprecated in favor of "channel://php-src/ext/fileinfo/in php sources

"WARNING: channel "pear.php.net" has updated its protocols, use "pecl channel-update pear.php.net" to update

downloading Fileinfo-1.0.4.tgz ...

Starting to download Fileinfo-1.0.4.tgz (5,835 bytes)

.....done: 5,835 bytes

3 source files, building

running: phpize

Cannot find config.m4.

Make sure that you run '/usr/local/bin/phpize' in the top level source directory of the module

ERROR: `phpize' failed

Ответы на вопрос(3)

Вы устанавливаете php-devel?
phpize выполнить пакет php-devel для нужд. если вы находитесь на centos, запустите следующий код

yum install php-devel
 vchakoshy18 апр. 2012 г., 16:58
вам нужно установить пакет epel yum для установки по этой ссылкессылк
 kenorb05 мар. 2014 г., 16:05
На CentOS попробуйте:sudo yum --enablerepo=remi,remi-php54 install php-devel
 Lalit Arora18 апр. 2012 г., 11:29
Я попробовал указанную вами команду, но она приводит к следующему: Настройка процесса установки Нет пакета php-devel. Ошибка: нечего делать
Решение Вопроса

einfo была расширением PECL, но там больше не поддерживается. Однако версии до 5.3+ могут использовать прекращено расширение PECL.

Ссылка

http: //www.php.net/manual/en/fileinfo.installation.ph

ERROR: `phpize' failed

Эта ошибка отображается, потому что у вас нетphp-devel пакет установлен

 Lalit Arora18 апр. 2012 г., 11:29
Как я могу установить php-devel через whm или putty.

Для меня это работает

#yum install rh-php70-php-devel

https: //centos.pkgs.org/7/centos-sclo-rh/rh-php70-php-devel-7.0.10-2.el7.x86_64.rpm.htm

Ваш ответ на вопрос