Какие браузеры поддерживают HTML 5 <audio> тег на винде сегодня?

Какие браузеры поддерживают HTML 5<audio> тег на винде сегодня?

Редактировать: Попыткаhttp://moztw.org/demo/audioplayer/ в качестве теста. Chrome 2 и Safari 4 не работают для меня.

 Jon Tackabury17 июн. 2009 г., 16:06
Хороший вопрос. Я не уверен, почему люди голосуют за закрытие, зная, на какие браузеры ориентироваться, это определенно связано с программированием.
 Boris Callens14 янв. 2010 г., 09:36
Проблема с этим вопросом в том, что он устарел ..
 BenB17 июн. 2009 г., 16:09
Мистер Шини и Нью, это работает в названии, это работает в & lt; comments & gt; так что да, это его вина.
 BenB17 июн. 2009 г., 16:08
Чтобы было ясно, я пытаюсь найти тот, который работает сmoztw.org/demo/audioplayer
 Mr. Shiny and New 安宇17 июн. 2009 г., 16:06
Вы могли бы использовать обратные галочки для создания & lt; audio & gt; в качестве кода, или же использовать HTML-сущности. Редактор позволяет форматировать HTML. Не ТАК вина, что вы не знаете, как это работает.

Ответы на вопрос(10)

анал разработчика)

!!document.createElement('audio').canPlayType

, тогда у вас есть поддержка аудио тегов в вашем браузере. Подобное обнаружение гораздо лучше, чем анализ строк userAgent.

Кроме того, вы можете использовать что-то вродеModernizr справиться с этим обнаружить и многое другое для вас.

 01 окт. 2010 г., 08:46
Другие идеи / инструменты для определения поддержки: Погрузитесь в HTML5 ссылкуdiveintohtml5.org/everything.html jPlayerhappyworm.com/jquery/jplayer/HTML5.Audio.Support
 25 окт. 2016 г., 15:45
 25 окт. 2016 г., 15:45
Пол, но на моем устройстве ваш javascript-код вернул true, но звуковой тег все еще не работает. Mozilla / 5.0 (Linux; U; Android 4.1.2; en-us; GT-S5282 Build / JZO54K) AppleWebKit / 534.30 ( KHTML, как Gecko) Версия / 4.0 Mobile Safari / 534.30 & quot; Скриншот:

он поддерживается частично или полностью в движках gecko, webkit и presto.

Таким образом, любой браузер, который использует последнюю версию этих движков, должен поддерживать его.

список когда браузеры начал поддерживать аудио тег и какие аудио форматы они поддерживают.

Поддержка довольно хорошая сейчас. Начиная с IE9, последние версии всех настольных браузеров и большинства мобильных браузеров поддерживают звуковую метку. Единственная причина не использовать его - поддержка старых версий IE, но вы всегда можете предоставить запасной вариант, если это важно.

Вот детали для настольных браузеров:

+---------+-------------------------+----------------------------------+
| Browser | Supported since version |             Formats              |
+---------+-------------------------+----------------------------------+
| IE      | 9.0                     | AAC or .mp3                      |
| Firefox | 3.5                     | .ogg, .wav                       |
| Chrome  | 3                       | .mp3, .ogg                       |
| Safari  | 4                       | Any audio supported by Quicktime |
| Opera   | 9.5                     | .ogg, .wav                       |
+---------+-------------------------+----------------------------------+

Вот детали для мобильных браузеров (нет информации о формате, извините):

+--------------+-------------------------+
|   Browser    | Supported since version |
+--------------+-------------------------+
| iOS Safari   | 4                       |
| Opera mobile | 10                      |
| Opera mini   | no support (Dec 2011)   |
| Android      | 2.3                     |
| Blackberry   | 6                       |
+--------------+-------------------------+

Если вы хотите использовать аудио, оноважно предоставить версии файла .ogg и .mp3 чтобы получить хорошую поддержку кросс-браузер.

<audio controls>
   <source src="/my-podcast.mp3" />
   <source src="/my-podcast.ogg" />
</audio>
 14 янв. 2010 г., 09:35
опера не AFAIK
 01 окт. 2010 г., 08:45
Вероятно, лучше всего не принимать решения на основе статей Википедии. попробуйте вместо этого Моденизрmodernizr.com
 BenB17 июн. 2009 г., 16:13
Это также обмануло меня, поскольку в этой статье нет упоминаний о версиях. Кроме того, я много слышу о HTML 5 & lt; video & gt; Поддержка в эти дни, так что либо эта страница не так, либо она устарела?

сообщение.

Содержит более актуальную информацию о современной поддержке браузером HTML5 аудио.

As of July 2011

IE9

Поддерживает MP3 и AAC

Firefox 5

Поддерживает Ogg и WAV

Chrome 12

Поддерживает Ogg, MP3, WAV и AAC

Safari 5

Поддерживает MP3, AAC и WAV

Opera 11

Поддерживает Ogg и WAV

Как видно из приведенных выше данных и чтения блога, ситуация немного разочаровывающая, поскольку не все аудиоформаты поддерживаются всеми браузерами. Также нет никаких непосредственных признаков какого-либо решения.

Решение Вопроса

not поддерживать аудио элемент, хотя он поддерживает более старую версию в форме аудио объекта. Chrome 3, вероятно, будет поддерживать аудио элемент.

(Только что увидел, что вы хотели бы узнать о поддержке этой конкретной страницы. Это в основном зависит от кодеков, которые вы используете, я боюсь.)

(Отказ от ответственности: я работаю в Opera и являюсь членом HTML WG.)

 31 янв. 2012 г., 04:51
так что мы снова вернулись к плагинам с сафари / facepalm
 BenB18 июн. 2009 г., 01:39
Приветствия. Тем не менее, я попробовал Safari 4 на странице Moz, и он, похоже, не работает. Если у вас есть время, не могли бы вы подтвердить?
 13 февр. 2011 г., 00:03
Они процитировали этот ответ в этой статье, отличная работа :)html5doctor.com/native-audio-in-the-browser
 17 июн. 2009 г., 21:24
+1: самый полезный ответ дан.
 19 июн. 2009 г., 17:55
Как я и подозревал, причина в кодеках. Safari использует QuickTime, который по умолчанию не поддерживает кодеки Ogg / Theora / Vorbis, с которыми поставляется Firefox 3.5. Вам нужно будет установитьxiph.org/quicktime/download.html и тогда это должно работать, насколько я могу судить.

википедия статья, сравнивающая поддержку HTML5 каждого браузера:

 BenB17 июн. 2009 г., 16:13
Это также обмануло меня, поскольку в этой статье нет упоминаний о версиях. Кроме того, я много слышу о HTML 5 & lt; video & gt; Поддержка в эти дни, так что либо эта страница не так, либо она устарела?
 01 окт. 2010 г., 08:45
Вероятно, лучше всего не принимать решения на основе статей Википедии. попробуйте вместо этого Моденизрmodernizr.com

необходимо установить Quicktime. Фрагмент javascript сообщает правильно, поддерживается он или нет.

что движки Gecko, Webkit и Presto поддерживают его, но я думаю, что только частично. Так что Firefox 3.5 и Opera - ваш лучший выбор.

по которой ваш плеер не работает в Safari, заключается в том, что вы используете файлы OGG. OGG поддерживается в Firefox и Chrome.
Firefox поддерживает только WAV и OGG. Chrome поддерживает все. Opera поддерживает только WAV. Safari поддерживает все, кроме OGG.

Удачи!

Ваш ответ на вопрос