новый macbook - пытаясь запустить Rails, теперь я получаю «internal: gem_prelude>: 1: в` require ': не могу загрузить такой файл - rubygems.rb (LoadError) »

Я купил новый Macbook Pro и использовал помощника по переходу с моего старого iMac.

Когда я пытаюсь запустить Rails или даже установить пакет, я получаю:

internal:gem_prelude>:1:in `require': cannot load such file -- rubygems.rb (LoadError)
from :1:in `'

Я получаю следующее:

$ ruby -v
ruby 1.9.3p374 (2013-01-15 revision 38858) [x86_64-darwin12.2.0]

Мой пользователь на iMac был burtondav, на Macbook Pro это Дэвидбертон. Я нене знаю, если этоэто причина.

Спасибо за помощь!

 Reddirt23 июн. 2013 г., 23:27
Спасибо! Это сработало!
 Mike Szyndel24 июн. 2013 г., 08:19
Я просто хотел добавить этоЭто не лучшая вещь. Подумайте о переустановке Ruby.
 Mike Szyndel23 июн. 2013 г., 21:58
Вы можете попробовать символическую ссылкуln -s /Users/davidburton /Users/burtondav

Ответы на вопрос(2)

Решение Вопроса

Вы можете попробовать символическую ссылку

ln -s /Users/davidburton /Users/burtondav

но правильным решением было бы переустановить ruby & RubyGems.

 Paul Draper06 нояб. 2015 г., 21:27
Неработающей ссылке.....

Ваш ответ на вопрос