Хватит ли Xcode 4.3.2 для создания приложений для iOS 6?

После сегодняшнего объявления о том, что бета-версия iOS 6 доступна для разработчиков сегодня, мне интересно, прыгну ли я на iOS 6 как можно скорее, смогу ли я создавать приложения на своем устройстве (iPhone) из Xcode 4.3.2? или будет также необходимое обновление для Xcode?

Обновление: в настоящее время у меня есть iOS 6 на моем iPhone и Xcode 4.5 установлен. После этого организатор в Xcode (4.3.2 и 4.5) сказал, что «не может поддерживать разработку». в обеспечении. Затем исправил это, и теперь у меня есть 4.3.2, говорящая, что оно запускает мое приложение на моем iPhone, но не отображается на моем телефоне. И 4,5 попадает в «TakingInstallLock» точка в процессе, и просто продолжает пытаться, но не получится. Кто-нибудь еще с этим вопросом? Кто-нибудь знает решение?

 Can Poyrazoğlu12 июн. 2012 г., 04:55
я обновился до ios 6 и теперь не могу тестировать мои приложения 5.1 на моем устройстве ios 6. пытаясь найти обходной путь, хотя.
 William LeGate23 июн. 2012 г., 21:37
Ты можешь это сделать. Видеть это:stackoverflow.com/questions/11172231/…
 tarheel12 июн. 2012 г., 05:07
Дайте нам всем знать, когда вы это сделаете. Это помогло бы всем нам!
 Samuel Spencer11 июн. 2012 г., 21:52
перед загрузкой Xcode 4.5 или iOS 6 обязательно прочитайте предупреждения: «Предварительный просмотр Xcode 4.5 Developer нельзя использовать для отправки приложений в iOS или Mac App Store. Продолжайте использовать общедоступную версию XCode для компиляции и отправки приложений в магазины приложений. & Quot;

Ответы на вопрос(5)

написанные вами с использованием бета-версии, будут отклонены. То есть, если вы используете бета-версию iOS 6 SDK или новую бета-версию Xcode, которая выходит сегодня, ваше приложение будет отклонено, даже если вы создадите сборку только для iOS 5.

 tarheel12 июн. 2012 г., 03:18
Я только что говорил об обновлении моего устройства.
 11 июн. 2012 г., 21:31
Я думаю, что он хотел обновить свое устройство до iOS 6

так что это подтверждает, что при установке Xcode 4.5 DP также автоматически устанавливается iOS 6 SDK для Xcode 4.3.2. Это довольно очевидно, поскольку файлы SDK устанавливаются в общем месте (а именно в папке «Библиотека») OSX.

Шаги для использования вашего обновленного устройства iOS 6 для разработки с Xcode 4.3.2, таким образом:

Загрузите Xcode 4.5 DP из области разработки apple.com.

Установите Xcode 4.5

Запустите Xcode 4.3.2

Откройте раздел «Устройства», выберите устройство для разработки, дождитесь окончания процесса извлечения информации, и все готово.

С уважением!

 13 июн. 2012 г., 17:32
Итак, вы сделали все эти шаги? Можете ли вы сейчас создавать свои приложения на обновленном устройстве ios 6 из Xcode 4.3.2 ???
 13 июн. 2012 г., 23:04
Пробовал ... и да! Работает отлично: D Спасибо
 13 июн. 2012 г., 21:09
Да. На моем iPhone 4 установлена iOS Beta 6, и я могу развернуть приложения из Xcode 4.3.2 с помощью iOS 6 SDK Beta, поставляемой с установкой Xcode 4.5. Во время установки нет подводных камней, так что вы можете просто попробовать и попробовать сами!

Я обновил вчера вечером, и теперь я не могу запустить свое приложение на своем телефоне.

 12 июн. 2012 г., 11:22
Тоже самое. Я предполагаю, что нам тоже нужно обновить бета-версию Xcode? Но придется ли тогда удалять это и переустанавливать 4.3.2 перед созданием приложения для отправки?
 12 июн. 2012 г., 18:02
Это не работает для меня. Установил 4.5, но по-прежнему не могу собрать на телефоне ни 4.3.3, ни 4.5
 12 июн. 2012 г., 11:27
Я только что прочитал заметки о выпуске для Xcode 4.5, и кажется, что он устанавливается как отдельный пакет. Итак, я думаю, нам нужно установить оба на данный момент. Используйте 4.5, чтобы протестировать ваше приложение, затем 4.3.2, чтобы отправить его.

а Xcode 4.3.2 не распознал мое устройство. После установки бета-версии Xcode 4.5 и возможности установки нескольких вещей, 4.3.2 теперь распознает мое устройство, и я могу продолжить сборку и тестирование на своем устройстве iOS6.

 tarheel15 июн. 2012 г., 18:59
Я сделал это, и мой iMac с 2011 года, работающий под управлением OS X 10.7.4, считает, что я хочу работать на «Мой 64-битный Mac». при использовании 4.3.2, но отлично работает с 4.5.
 12 июн. 2012 г., 18:09
На самом деле, я только что сделал другой Mac, который получил Xcode 4.3.3. Я могу собрать и запустить нормально, не установив 4.5. Вам нужно подождать около 10 минут, пока он загружает данные с телефона, просто посмотрите Организатор, и вы должны увидеть, как он загружается.
 tarheel12 июн. 2012 г., 17:41
Кто-нибудь еще может подтвердить, что они испытали то же самое? Я попробую позже, когда вернусь домой с работы.
Решение Вопроса

если ваш телефон работает под управлением iOS 6 Beta.

Однако вы не можете использовать ни одну из платформ iOS 6+, например новую социальную платформу, из Xcode 4.3.x

 21 июн. 2012 г., 08:24
Подтверждение, что я могу создавать и устанавливать приложения, используя органайзер для ios6 бета ipod, используя Xcode 4.3.3 ....
 21 июн. 2012 г., 07:12
OP может следовать инструкциям предыдущего обновления Xcode, вы можете перейти на ios6 на Xcode 4.0, если клонируете несколько каталогов из Xcode-4.5.dmg в соответствующую папку поддерживаемых устройств / симуляторов.stackoverflow.com/questions/9613565
 25 июн. 2012 г., 17:38
Подтверждая, что я могу собрать + синхронизировать приложение на XCode 4.2 с устройством iOS6, ... но без особых средств отладки (лучше обновить до последней версии OSX ;-) Я пропустил клонирование 1 каталога выше.
 08 июл. 2012 г., 09:40
Как вы поставили приложение на iOS6? В моем органайзере написано: Версия iOS для & # x201C; xxxx & # x201D; не соответствует ни одной из версий iOS, поддерживаемых для разработки, с этой установкой iOS SDK. Восстановите устройство до версии ОС, указанной ниже, или обновите до последней версии iOS SDK; который доступен здесь.

Ваш ответ на вопрос